aboutsummaryrefslogtreecommitdiffstats
path: root/security/openvas-libnasl
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2009-07-16 00:47:45 +0800
committerwxs <wxs@FreeBSD.org>2009-07-16 00:47:45 +0800
commit5df5244832441b2891d52b6e4692f7826550fbf9 (patch)
treee5cc110a0c6b72dd9bb7f133efd52b77ab031c63 /security/openvas-libnasl
parent194d70d50158859e626cd148123bb52dec698a06 (diff)
downloadfreebsd-ports-gnome-5df5244832441b2891d52b6e4692f7826550fbf9.tar.gz
freebsd-ports-gnome-5df5244832441b2891d52b6e4692f7826550fbf9.tar.zst
freebsd-ports-gnome-5df5244832441b2891d52b6e4692f7826550fbf9.zip
- Chase security/gpgme update.
Most changes are just PORTREVISION and LIB_DEPENDS fixes. However, the following ports require a patch to use the new gpgme correctly: deskutils/kdepim3 deskutils/kdepim3 deskutils/kdepim3 deskutils/kdepim3 deskutils/kdepim4 deskutils/kdepim4 deskutils/kdepimlibs4 deskutils/kdepimlibs4 deskutils/kdepimlibs4 finance/qhacc mail/mutt-devel net-im/ayttm net-im/centericq net-im/centerim net-im/centerim-devel security/openvas-libnasl These patches were submitted by various people and documented in ports/135911. PR: ports/135911
Diffstat (limited to 'security/openvas-libnasl')
-rw-r--r--security/openvas-libnasl/Makefile4
-rw-r--r--security/openvas-libnasl/files/patch-nasl__nasl_signature.c11
2 files changed, 13 insertions, 2 deletions
diff --git a/security/openvas-libnasl/Makefile b/security/openvas-libnasl/Makefile
index 47699a4a5acb..9954e5cc946a 100644
--- a/security/openvas-libnasl/Makefile
+++ b/security/openvas-libnasl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= openvas-libnasl
PORTVERSION= 1.0.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security
MASTER_SITES= http://wald.intevation.org/frs/download.php/406/
@@ -17,7 +17,7 @@ COMMENT= NASL libraries for OpenVAS
LIB_DEPENDS= gcrypt.16:${PORTSDIR}/security/libgcrypt \
gnutls.26:${PORTSDIR}/security/gnutls \
gpg-error.0:${PORTSDIR}/security/libgpg-error \
- gpgme.17:${PORTSDIR}/security/gpgme \
+ gpgme.18:${PORTSDIR}/security/gpgme \
openvas.1:${PORTSDIR}/security/openvas-libraries \
openvas_hg.1:${PORTSDIR}/security/openvas-libraries \
tasn1.4:${PORTSDIR}/security/libtasn1
diff --git a/security/openvas-libnasl/files/patch-nasl__nasl_signature.c b/security/openvas-libnasl/files/patch-nasl__nasl_signature.c
new file mode 100644
index 000000000000..c8bd3cff8cca
--- /dev/null
+++ b/security/openvas-libnasl/files/patch-nasl__nasl_signature.c
@@ -0,0 +1,11 @@
+--- ./nasl/nasl_signature.c.orig 2009-07-01 23:08:30.000000000 -0400
++++ ./nasl/nasl_signature.c 2009-07-01 23:09:42.000000000 -0400
+@@ -131,6 +131,8 @@
+ gpgme_data_t sig = NULL, text = NULL;
+ char * gpghome = determine_gpghome();
+
++ gpgme_check_version (NULL);
++
+ err = gpgme_engine_check_version(GPGME_PROTOCOL_OpenPGP);
+ if (err)
+ {