aboutsummaryrefslogtreecommitdiffstats
path: root/security/openvpn
diff options
context:
space:
mode:
authormandree <mandree@FreeBSD.org>2013-01-20 10:55:48 +0800
committermandree <mandree@FreeBSD.org>2013-01-20 10:55:48 +0800
commit8c21a8590d0077a734d122a592f1c0026bdb1fc3 (patch)
tree40d570cad3abf73fd479bea85e538fcfd17c80d8 /security/openvpn
parent32c629d0990b259c79d5f30381ba89c2abbc25d4 (diff)
downloadfreebsd-ports-gnome-8c21a8590d0077a734d122a592f1c0026bdb1fc3.tar.gz
freebsd-ports-gnome-8c21a8590d0077a734d122a592f1c0026bdb1fc3.tar.zst
freebsd-ports-gnome-8c21a8590d0077a734d122a592f1c0026bdb1fc3.zip
- When installing from port, do not tamper with permissions of other files
in ${PREFIX}/sbin and ${PREFIX}/lib. [1] - Do not install plugin .la/.so files with the executable bit set, they are not executable. PR: ports/175434 [1] Submitted by: Benjamin Lorenz [1]
Diffstat (limited to 'security/openvpn')
-rw-r--r--security/openvpn/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/security/openvpn/Makefile b/security/openvpn/Makefile
index 2acf38b44c64..a3cdd6640b2e 100644
--- a/security/openvpn/Makefile
+++ b/security/openvpn/Makefile
@@ -3,7 +3,7 @@
PORTNAME= openvpn
DISTVERSION= 2.3.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security net
MASTER_SITES= http://swupdate.openvpn.net/community/releases/ \
http://build.openvpn.net/downloads/releases/
@@ -91,10 +91,10 @@ post-build:
.endif
post-install:
- ${MKDIR} ${PREFIX}/lib ${PREFIX}/sbin ${PREFIX}/include ${PREFIX}/man
-.for i in lib sbin
- (cd ${_stagedir}${PREFIX}/${i} && ${COPYTREE_BIN} \* ${PREFIX}/${i}/)
-.endfor
+ ${MKDIR} ${PREFIX}/lib/openvpn/plugins/ ${PREFIX}/sbin \
+ ${PREFIX}/include ${PREFIX}/man
+ ${INSTALL_PROGRAM} ${_stagedir}${PREFIX}/sbin/openvpn ${PREFIX}/sbin
+ ${INSTALL_DATA} ${_stagedir}${PREFIX}/lib/openvpn/plugins/* ${PREFIX}/lib/openvpn/plugins/
${INSTALL_DATA} ${_stagedir}${PREFIX}/include/* ${PREFIX}/include/
${INSTALL_MAN} ${_stagedir}${PREFIX}/man/man8/* ${MAN8PREFIX}/man/man8/
.if ${PORT_OPTIONS:MDOCS}