aboutsummaryrefslogtreecommitdiffstats
path: root/security/openvpn
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2006-10-03 01:47:32 +0800
committeralepulver <alepulver@FreeBSD.org>2006-10-03 01:47:32 +0800
commit41387eede320d14d7686fb64f86de5edb711b772 (patch)
treef28f5e75c0523b05caedc67e793ad79c870d93eb /security/openvpn
parent85f3b43aa673e4494959a8fe655ef04f82a2e332 (diff)
downloadfreebsd-ports-gnome-41387eede320d14d7686fb64f86de5edb711b772.tar.gz
freebsd-ports-gnome-41387eede320d14d7686fb64f86de5edb711b772.tar.zst
freebsd-ports-gnome-41387eede320d14d7686fb64f86de5edb711b772.zip
- Fix build failures that arose from an accidentally omitted -fPIC.
- Portrevision bumped since the change affects all architectures, not just those that were failing. PR: ports/103863 Submitted by: Matthias Andree <matthias.andree@gmx.de> (maintainer) Reported by: pointyhat
Diffstat (limited to 'security/openvpn')
-rw-r--r--security/openvpn/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/security/openvpn/Makefile b/security/openvpn/Makefile
index e86d9ac8d3a7..93cc19cacbec 100644
--- a/security/openvpn/Makefile
+++ b/security/openvpn/Makefile
@@ -10,10 +10,10 @@ PORTNAME= openvpn
# DO NOT BOTHER TO SEND NOTICES ABOUT 2.0.8 AS IT FIXES
# WINDOWS-ONLY BUGS THAT DON'T AFFECT *BSD AND THUS
# DOES NOT WARRANT A PORT UPGRADE! AND UPGRADE REQUESTS
-# WILL BE DROPPED. -- Matthias Andree, 2006-09-13
+# WILL BE DROPPED. -- Matthias Andree, 2006-10-01
# -----------------------------------------------------
PORTVERSION= 2.0.6
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= security net
# MASTER_SITES points to hosts in distinct data centers,
# so just one MASTER_SITES entry should be OK.
@@ -65,7 +65,7 @@ CONFIGURE_ARGS+= --enable-password-save
post-build:
cd ${WRKSRC}/plugin/down-root && ${MAKE}
- cd ${WRKSRC}/plugin/auth-pam && ${CC} ${CFLAGS} ${CPPFLAGS} -I../.. -DDLOPEN_PAM=0 -shared -Wl,-soname,openvpn-auth-pam.so -o openvpn-auth-pam.so auth-pam.c pamdl.c -lc -lpam
+ cd ${WRKSRC}/plugin/auth-pam && ${CC} ${CPPFLAGS} -I../.. -DDLOPEN_PAM=0 ${CFLAGS} -fPIC -shared -Wl,-soname,openvpn-auth-pam.so -o openvpn-auth-pam.so auth-pam.c pamdl.c -lc -lpam
@# self-tests here
.if !defined(WITHOUT_CHECK)
cd ${WRKSRC} && ${MAKE} check