aboutsummaryrefslogtreecommitdiffstats
path: root/security/ophcrack
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2014-03-10 17:45:28 +0800
committerdanfe <danfe@FreeBSD.org>2014-03-10 17:45:28 +0800
commit2ce528313b9255d0f78717769cb2dcffc5c6e97e (patch)
tree227af7c84018575e065b9f76bf0a6a7db10ca351 /security/ophcrack
parent7d2f6f04d06b371e1d32c1ef36057014c758b4a0 (diff)
downloadfreebsd-ports-gnome-2ce528313b9255d0f78717769cb2dcffc5c6e97e.tar.gz
freebsd-ports-gnome-2ce528313b9255d0f78717769cb2dcffc5c6e97e.tar.zst
freebsd-ports-gnome-2ce528313b9255d0f78717769cb2dcffc5c6e97e.zip
Stagify; convert LIB_DEPENDS and USE_GMAKE.
Diffstat (limited to 'security/ophcrack')
-rw-r--r--security/ophcrack/Makefile14
1 files changed, 5 insertions, 9 deletions
diff --git a/security/ophcrack/Makefile b/security/ophcrack/Makefile
index 405c777b74fd..33d944726852 100644
--- a/security/ophcrack/Makefile
+++ b/security/ophcrack/Makefile
@@ -12,18 +12,18 @@ COMMENT= Windows password cracker based on rainbow tables
LICENSE= APACHE20 GPLv2
LICENSE_COMB= multi
-LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2
+USES= gmake
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_GMAKE= yes
USE_OPENSSL= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
PLIST_FILES= bin/ophcrack
-PORTDOCS= *
+PORTDOCS= ChangeLog README
OPTIONS_DEFINE= X11 GRAPH DOCS
OPTIONS_DEFAULT= X11 GRAPH
@@ -31,7 +31,6 @@ OPTIONS_DEFAULT= X11 GRAPH
X11_DESC= Build Qt 4 GUI frontend
GRAPH_DESC= Enable graph rendering via Qwt
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MX11} || ${PORT_OPTIONS:MGRAPH}
@@ -47,11 +46,8 @@ CONFIGURE_ARGS+= --disable-graph
.endif
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/ChangeLog ${WRKSRC}/README ${DOCSDIR}
-.endif
- @${ECHO_MSG} ; ${CAT} ${PKGMESSAGE} ; ${ECHO_MSG}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
BROKEN= Does not compile on ia64, powerpc, or sparc64