aboutsummaryrefslogtreecommitdiffstats
path: root/security/p5-Authen-Htpasswd/Makefile
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2005-11-11 21:45:53 +0800
committertobez <tobez@FreeBSD.org>2005-11-11 21:45:53 +0800
commitf1437917e6331aa1b51432f3d1cfcadec60cfea5 (patch)
treea7a841d58765df6214a5857e928b777bbdaf837c /security/p5-Authen-Htpasswd/Makefile
parent6a2775389958bf8de103d7254c5a71d3dd15968c (diff)
downloadfreebsd-ports-gnome-f1437917e6331aa1b51432f3d1cfcadec60cfea5.tar.gz
freebsd-ports-gnome-f1437917e6331aa1b51432f3d1cfcadec60cfea5.tar.zst
freebsd-ports-gnome-f1437917e6331aa1b51432f3d1cfcadec60cfea5.zip
Add security/p5-Authen-Htpasswd 0.12, a Perl module to read and modify
apache-style .htpasswd files.
Diffstat (limited to 'security/p5-Authen-Htpasswd/Makefile')
-rw-r--r--security/p5-Authen-Htpasswd/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/security/p5-Authen-Htpasswd/Makefile b/security/p5-Authen-Htpasswd/Makefile
new file mode 100644
index 000000000000..8e98e4faf711
--- /dev/null
+++ b/security/p5-Authen-Htpasswd/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: security/p5-Authen-Htpasswd
+# Date created: 11 November 2005
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Authen-Htpasswd
+PORTVERSION= 0.12
+CATEGORIES= security perl5 www
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Authen
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Authen::Htpasswd - interface to read and modify Apache .htpasswd files
+TAGS= apache authentication pass password md5 sha1 crypto
+
+BUILD_DEPENDS= ${SITE_PERL}/IO/LockedFile.pm:${PORTSDIR}/devel/p5-IO-LockedFile \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1 \
+ ${SITE_PERL}/Crypt/PasswdMD5.pm:${PORTSDIR}/security/p5-Crypt-PasswdMD5 \
+ ${SITE_PERL}/Class/Accessor/Fast.pm:${PORTSDIR}/devel/p5-Class-Accessor
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Authen::Htpasswd.3 \
+ Authen::Htpasswd::User.3 \
+ Authen::Htpasswd::Util.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>