aboutsummaryrefslogtreecommitdiffstats
path: root/security/p5-Authen-Simple-SSH
diff options
context:
space:
mode:
authoraaron <aaron@FreeBSD.org>2006-05-23 01:09:14 +0800
committeraaron <aaron@FreeBSD.org>2006-05-23 01:09:14 +0800
commit60c5893a91f81404f28a05866ca446ca442749c4 (patch)
tree5a3669ba585dfc9b167c477d534edfd20747498a /security/p5-Authen-Simple-SSH
parent65079eb6f7fedaf387054eee052829e154681f82 (diff)
downloadfreebsd-ports-gnome-60c5893a91f81404f28a05866ca446ca442749c4.tar.gz
freebsd-ports-gnome-60c5893a91f81404f28a05866ca446ca442749c4.tar.zst
freebsd-ports-gnome-60c5893a91f81404f28a05866ca446ca442749c4.zip
Adding port security/p5-Authen-Simple-SSH, SSH protocol extension for security/p5-Authen-Simple.
Approved by: tobez (implicit)
Diffstat (limited to 'security/p5-Authen-Simple-SSH')
-rw-r--r--security/p5-Authen-Simple-SSH/Makefile32
-rw-r--r--security/p5-Authen-Simple-SSH/distinfo3
-rw-r--r--security/p5-Authen-Simple-SSH/pkg-descr4
-rw-r--r--security/p5-Authen-Simple-SSH/pkg-plist3
4 files changed, 42 insertions, 0 deletions
diff --git a/security/p5-Authen-Simple-SSH/Makefile b/security/p5-Authen-Simple-SSH/Makefile
new file mode 100644
index 000000000000..4e7442ed7c3c
--- /dev/null
+++ b/security/p5-Authen-Simple-SSH/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: Authen-Simple-SSH
+# Date created: 22 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Authen-Simple-SSH
+PORTVERSION= 0.1
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Authen
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Simple SSH authentication
+
+BUILD_DEPENDS= ${SITE_PERL}/Authen/Simple.pm:${PORTSDIR}/security/p5-Authen-Simple \
+ ${SITE_PERL}/Net/SSH/Perl.pm:${PORTSDIR}/net/p5-Net-SSH-Perl
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Authen::Simple::SSH.3
+
+PERL_MODBUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires at least Perl 5.8 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/p5-Authen-Simple-SSH/distinfo b/security/p5-Authen-Simple-SSH/distinfo
new file mode 100644
index 000000000000..c5499d80b7a6
--- /dev/null
+++ b/security/p5-Authen-Simple-SSH/distinfo
@@ -0,0 +1,3 @@
+MD5 (Authen-Simple-SSH-0.1.tar.gz) = e3330ae491096223b8c55de120daec91
+SHA256 (Authen-Simple-SSH-0.1.tar.gz) = a5482483a23ca68998c9e82ffaddc5c14920edb86b8e991572d294832cddead7
+SIZE (Authen-Simple-SSH-0.1.tar.gz) = 2674
diff --git a/security/p5-Authen-Simple-SSH/pkg-descr b/security/p5-Authen-Simple-SSH/pkg-descr
new file mode 100644
index 000000000000..2431b3ac694a
--- /dev/null
+++ b/security/p5-Authen-Simple-SSH/pkg-descr
@@ -0,0 +1,4 @@
+Authentication via SSH protocol.
+
+WWW: http://search.cpan.org/dist/Authen-Simple-Net-SSH
+Author: Christian Hansen <ch@ngmedia.com>
diff --git a/security/p5-Authen-Simple-SSH/pkg-plist b/security/p5-Authen-Simple-SSH/pkg-plist
new file mode 100644
index 000000000000..c524f96c8e2d
--- /dev/null
+++ b/security/p5-Authen-Simple-SSH/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/Authen/Simple/SSH.pm
+@dirrmtry %%SITE_PERL%%/Authen/Simple
+@dirrmtry %%SITE_PERL%%/Authen