aboutsummaryrefslogtreecommitdiffstats
path: root/security/p5-Crypt-DES/Makefile
diff options
context:
space:
mode:
authoraaron <aaron@FreeBSD.org>2005-12-10 04:16:33 +0800
committeraaron <aaron@FreeBSD.org>2005-12-10 04:16:33 +0800
commit189bc865d3ea939164fe10bb9e5a1d70f498711a (patch)
tree05fbc5d12289770da0108e423e39e6af0cd0d48d /security/p5-Crypt-DES/Makefile
parentb64923da77452b4eeb42c02f708801cc4f27b6dc (diff)
downloadfreebsd-ports-gnome-189bc865d3ea939164fe10bb9e5a1d70f498711a.tar.gz
freebsd-ports-gnome-189bc865d3ea939164fe10bb9e5a1d70f498711a.tar.zst
freebsd-ports-gnome-189bc865d3ea939164fe10bb9e5a1d70f498711a.zip
- Updated from v2.03 to v2.05
- Updated maintainership from ports@ to perl@ - Added dependency on Perl >= 5.6 since it is required by a dependency Approved by: tobez
Diffstat (limited to 'security/p5-Crypt-DES/Makefile')
-rw-r--r--security/p5-Crypt-DES/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/security/p5-Crypt-DES/Makefile b/security/p5-Crypt-DES/Makefile
index 5a63e46740c5..e73fc0ab709a 100644
--- a/security/p5-Crypt-DES/Makefile
+++ b/security/p5-Crypt-DES/Makefile
@@ -6,17 +6,26 @@
#
PORTNAME= Crypt-DES
-PORTVERSION= 2.03
+PORTVERSION= 2.05
CATEGORIES= security perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Crypt
PKGNAMEPREFIX= p5-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= perl@FreeBSD.org
COMMENT= Perl5 interface to DES block cipher
+BUILD_DEPENDS= ${SITE_PERL}/Crypt/CBC.pm:${PORTSDIR}/security/p5-Crypt-CBC
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
PERL_CONFIGURE= yes
MAN3= Crypt::DES.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= requires perl 5.6.x or later. Install lang/perl5 or lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>