aboutsummaryrefslogtreecommitdiffstats
path: root/security/p5-Crypt-ECB
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2004-12-27 18:10:51 +0800
committertobez <tobez@FreeBSD.org>2004-12-27 18:10:51 +0800
commit1fc49f48a6fdcc76e319b6c97168e9a173f57646 (patch)
treecd698f6c94a9e56a3df226a7aa32762aa7992c68 /security/p5-Crypt-ECB
parent7fe3f7dabf6abbbb2fdc10005d7ebff073a40422 (diff)
downloadfreebsd-ports-gnome-1fc49f48a6fdcc76e319b6c97168e9a173f57646.tar.gz
freebsd-ports-gnome-1fc49f48a6fdcc76e319b6c97168e9a173f57646.tar.zst
freebsd-ports-gnome-1fc49f48a6fdcc76e319b6c97168e9a173f57646.zip
Patch up for http://secunia.com/advisories/13566/
Diffstat (limited to 'security/p5-Crypt-ECB')
-rw-r--r--security/p5-Crypt-ECB/Makefile1
-rw-r--r--security/p5-Crypt-ECB/files/patch-ECB.pm11
2 files changed, 12 insertions, 0 deletions
diff --git a/security/p5-Crypt-ECB/Makefile b/security/p5-Crypt-ECB/Makefile
index a406f9474412..3232efabb65d 100644
--- a/security/p5-Crypt-ECB/Makefile
+++ b/security/p5-Crypt-ECB/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Crypt-ECB
PORTVERSION= 1.1p2
+PORTREVISION= 1
CATEGORIES= security perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Crypt
diff --git a/security/p5-Crypt-ECB/files/patch-ECB.pm b/security/p5-Crypt-ECB/files/patch-ECB.pm
new file mode 100644
index 000000000000..8a411655aa96
--- /dev/null
+++ b/security/p5-Crypt-ECB/files/patch-ECB.pm
@@ -0,0 +1,11 @@
+--- ECB.pm.orig Mon Dec 27 11:05:33 2004
++++ ECB.pm Mon Dec 27 11:06:45 2004
+@@ -274,7 +274,7 @@ sub finish (\$)
+ $crypt->{Mode} = '';
+ $crypt->{buffer} = '';
+
+- return '' unless $data;
++ return '' unless defined($data) && length($data) > 0;
+
+ my $cipher = $crypt->_getcipher;
+