aboutsummaryrefslogtreecommitdiffstats
path: root/security/p5-Crypt-Enigma
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2005-12-21 16:35:13 +0800
committererwin <erwin@FreeBSD.org>2005-12-21 16:35:13 +0800
commitb29ba0a8b473aa2e435d4e90a0626842fcefd8b4 (patch)
tree6027ac67bb7b87805e820696f560702c1d5a5ac8 /security/p5-Crypt-Enigma
parent2dcff3e9636b3595d02aa7ed41c784a551d5fabf (diff)
downloadfreebsd-ports-gnome-b29ba0a8b473aa2e435d4e90a0626842fcefd8b4.tar.gz
freebsd-ports-gnome-b29ba0a8b473aa2e435d4e90a0626842fcefd8b4.tar.zst
freebsd-ports-gnome-b29ba0a8b473aa2e435d4e90a0626842fcefd8b4.zip
This module is a complete working Perl implementation of the Enigma Machine
used during World War II. The cipher calculations are based on actual Enigma values and the resulting ciphered values are as would be expected from an Enigma Machine. The implementation allows for all of the Rotors and Reflectors available to the real world Enigma to be used. A Steckerboard has also been implemented, allowing letter substitutions to be made. WWW: http://search.cpan.org/dist/Crypt-Enigma PR: ports/90683 Submitted by: Gabor Kovesdan
Diffstat (limited to 'security/p5-Crypt-Enigma')
-rw-r--r--security/p5-Crypt-Enigma/Makefile24
-rw-r--r--security/p5-Crypt-Enigma/distinfo3
-rw-r--r--security/p5-Crypt-Enigma/pkg-descr9
-rw-r--r--security/p5-Crypt-Enigma/pkg-plist5
4 files changed, 41 insertions, 0 deletions
diff --git a/security/p5-Crypt-Enigma/Makefile b/security/p5-Crypt-Enigma/Makefile
new file mode 100644
index 000000000000..088a12a1c01f
--- /dev/null
+++ b/security/p5-Crypt-Enigma/Makefile
@@ -0,0 +1,24 @@
+# New ports collection Makefile for: p5-Crypt-Enigma
+# Date created: 20 Dec 2006
+# Whom: Gabor Kovesdan
+# $FreeBSD$
+
+PORTNAME= Crypt-Enigma
+PORTVERSION= 1.3
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gkovesdan@t-hosting.hu
+COMMENT= Perl extension for the Enigma cipher
+
+PERL_CONFIGURE= yes
+
+MAN3= Crypt::Enigma.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/security/p5-Crypt-Enigma/distinfo b/security/p5-Crypt-Enigma/distinfo
new file mode 100644
index 000000000000..6cadc6dc7479
--- /dev/null
+++ b/security/p5-Crypt-Enigma/distinfo
@@ -0,0 +1,3 @@
+MD5 (Crypt-Enigma-1.3.tar.gz) = df345b5a952eb63ec37c1fc00776c9c8
+SHA256 (Crypt-Enigma-1.3.tar.gz) = e6f343c268d0a54eb403f9d9000470c557a933183df3bba53036a3e9cc90c587
+SIZE (Crypt-Enigma-1.3.tar.gz) = 6601
diff --git a/security/p5-Crypt-Enigma/pkg-descr b/security/p5-Crypt-Enigma/pkg-descr
new file mode 100644
index 000000000000..032a6afab126
--- /dev/null
+++ b/security/p5-Crypt-Enigma/pkg-descr
@@ -0,0 +1,9 @@
+This module is a complete working Perl implementation of the Enigma Machine
+used during World War II. The cipher calculations are based on actual Enigma
+values and the resulting ciphered values are as would be expected from an
+Enigma Machine.
+The implementation allows for all of the Rotors and Reflectors available to the
+real world Enigma to be used. A Steckerboard has also been implemented,
+allowing letter substitutions to be made.
+
+WWW: http://search.cpan.org/dist/Crypt-Enigma
diff --git a/security/p5-Crypt-Enigma/pkg-plist b/security/p5-Crypt-Enigma/pkg-plist
new file mode 100644
index 000000000000..94d914953dfa
--- /dev/null
+++ b/security/p5-Crypt-Enigma/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Crypt/Enigma.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/Enigma/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/Enigma/
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Crypt 2>/dev/null || true