aboutsummaryrefslogtreecommitdiffstats
path: root/security/p5-Crypt-OpenSSL-RSA/Makefile
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-09-11 17:22:34 +0800
committerknu <knu@FreeBSD.org>2001-09-11 17:22:34 +0800
commit3fdd6e78542ec9a74c215144b390c2b03674497d (patch)
treec7b721ba5ac9510432955c2d8ada4871a654e06c /security/p5-Crypt-OpenSSL-RSA/Makefile
parent4bc03442ee34df9ca01a41f76f14b62bb50fc867 (diff)
downloadfreebsd-ports-gnome-3fdd6e78542ec9a74c215144b390c2b03674497d.tar.gz
freebsd-ports-gnome-3fdd6e78542ec9a74c215144b390c2b03674497d.tar.zst
freebsd-ports-gnome-3fdd6e78542ec9a74c215144b390c2b03674497d.zip
Add p5-Crypt-OpenSSL-RSA, a Perl5 module to RSA encode and decode
strings using OpenSSL. PR: ports/30106 Submitted by: Norikatsu Shigemura <nork@cityfujisawa.ne.jp>
Diffstat (limited to 'security/p5-Crypt-OpenSSL-RSA/Makefile')
-rw-r--r--security/p5-Crypt-OpenSSL-RSA/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/security/p5-Crypt-OpenSSL-RSA/Makefile b/security/p5-Crypt-OpenSSL-RSA/Makefile
new file mode 100644
index 000000000000..6cfe6fcf6b61
--- /dev/null
+++ b/security/p5-Crypt-OpenSSL-RSA/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Crypt-OpenSSL-RSA
+# Date created: 2001/08/27
+# Whom: nork@cityfujisawa.ne.jp
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt-OpenSSL-RSA
+PORTVERSION= 0.11
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= nork@cityfujisawa.ne.jp
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Crypt/OpenSSL/Random.pm:${PORTSDIR}/local/p5-Crypt-OpenSSL-Random
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+RESTRICTED= "Crypto; export-controlled"
+
+PERL_CONFIGURE= yes
+
+MAN3= Crypt::OpenSSL::RSA.3
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>