aboutsummaryrefslogtreecommitdiffstats
path: root/security/p5-Crypt-OpenSSL-RSA
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-05-26 16:58:21 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-05-26 16:58:21 +0800
commit45df7a3693a04e8f3452f7c47bf209863eb8342e (patch)
treea04df838540921e6960e5d2073ff67564c0c45dc /security/p5-Crypt-OpenSSL-RSA
parenta9993e35aeee1c10cbb7cd5c371cfc0937885f37 (diff)
downloadfreebsd-ports-gnome-45df7a3693a04e8f3452f7c47bf209863eb8342e.tar.gz
freebsd-ports-gnome-45df7a3693a04e8f3452f7c47bf209863eb8342e.tar.zst
freebsd-ports-gnome-45df7a3693a04e8f3452f7c47bf209863eb8342e.zip
- Fix self test with Perl 5.14 [1]
- Add regression-test: - Make portlint happier - Bump PORTREVISION for RSA.pm change PR: ports/157187 [1] Submitted by: Mark Martinec <Mark.Martinec@ijs.si>
Diffstat (limited to 'security/p5-Crypt-OpenSSL-RSA')
-rw-r--r--security/p5-Crypt-OpenSSL-RSA/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/security/p5-Crypt-OpenSSL-RSA/Makefile b/security/p5-Crypt-OpenSSL-RSA/Makefile
index ae8722e9b1c0..539c632e8143 100644
--- a/security/p5-Crypt-OpenSSL-RSA/Makefile
+++ b/security/p5-Crypt-OpenSSL-RSA/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Crypt-OpenSSL-RSA
PORTVERSION= 0.26
+PORTREVISION= 1
CATEGORIES= security perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,14 +15,21 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl5 module to RSA encode and decode strings using OpenSSL
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Crypt/OpenSSL/Random.pm:${PORTSDIR}/security/p5-Crypt-OpenSSL-Random \
- ${SITE_PERL}/${PERL_ARCH}/Crypt/OpenSSL/Bignum.pm:${PORTSDIR}/security/p5-Crypt-OpenSSL-Bignum
-BUILD_DEPENDS= ${RUN_DEPENDS}
+BUILD_DEPENDS= p5-Crypt-OpenSSL-Bignum>=0:${PORTSDIR}/security/p5-Crypt-OpenSSL-Bignum \
+ p5-Crypt-OpenSSL-Random>=0:${PORTSDIR}/security/p5-Crypt-OpenSSL-Random
+RUN_DEPENDS= p5-Crypt-OpenSSL-Bignum>=0:${PORTSDIR}/security/p5-Crypt-OpenSSL-Bignum \
+ p5-Crypt-OpenSSL-Random>=0:${PORTSDIR}/security/p5-Crypt-OpenSSL-Random
PERL_CONFIGURE= yes
USE_OPENSSL= yes
-MAKE_ARGS+= PASTHRU_INC=-I${OPENSSLINC}
+MAKE_ARGS= PASTHRU_INC=-I${OPENSSLINC}
MAN3= Crypt::OpenSSL::RSA.3
+post-patch:
+ @${REINPLACE_CMD} -e "9 s|require AutoLoader;|use AutoLoader 'AUTOLOAD';|" ${WRKSRC}/RSA.pm
+
+regression-test: build
+ cd ${WRKSRC}/ && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_ARGS} test
+
.include <bsd.port.mk>