aboutsummaryrefslogtreecommitdiffstats
path: root/security/p5-Crypt-Random-Source
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-03-17 21:16:11 +0800
committermiwi <miwi@FreeBSD.org>2011-03-17 21:16:11 +0800
commit0d7b006ed077cdee12eb21e18dec6f349e5ae233 (patch)
tree539b7cfcc316ad48c83f5ee744e92ff3e007d4bb /security/p5-Crypt-Random-Source
parentea885b45f28faf54538c2ceeee625941464ab019 (diff)
downloadfreebsd-ports-gnome-0d7b006ed077cdee12eb21e18dec6f349e5ae233.tar.gz
freebsd-ports-gnome-0d7b006ed077cdee12eb21e18dec6f349e5ae233.tar.zst
freebsd-ports-gnome-0d7b006ed077cdee12eb21e18dec6f349e5ae233.zip
Get weak or strong random data from pluggable sources
WWW: http://search.cpan.org/dist/Crypt-Random-Source PR: ports/155572 Submitted by: Dereckson <dereckson at gmail.com>
Diffstat (limited to 'security/p5-Crypt-Random-Source')
-rw-r--r--security/p5-Crypt-Random-Source/Makefile41
-rw-r--r--security/p5-Crypt-Random-Source/distinfo2
-rw-r--r--security/p5-Crypt-Random-Source/pkg-descr3
-rw-r--r--security/p5-Crypt-Random-Source/pkg-plist22
4 files changed, 68 insertions, 0 deletions
diff --git a/security/p5-Crypt-Random-Source/Makefile b/security/p5-Crypt-Random-Source/Makefile
new file mode 100644
index 000000000000..e0d6b334f412
--- /dev/null
+++ b/security/p5-Crypt-Random-Source/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: Crypt::Random::Source
+# Date created: 15 March 2011
+# Whom: Dereckson <dereckson@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt-Random-Source
+PORTVERSION= 0.07
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= dereckson@gmail.com
+COMMENT= Get weak or strong random data from pluggable sources
+
+TEST_DEPENDS= p5-Test-Exception>0:${PORTSDIR}/devel/p5-Test-Exception \
+ p5-Test-use-ok>0:${PORTSDIR}/devel/p5-Test-use-ok
+RUN_DEPENDS= p5-Capture-Tiny>=0.08:${PORTSDIR}/devel/p5-Capture-Tiny \
+ p5-Module-Find>0:${PORTSDIR}/devel/p5-Module-Find \
+ p5-Sub-Exporter>0:${PORTSDIR}/devel/p5-Sub-Exporter \
+ p5-namespace-clean>=0.08:${PORTSDIR}/devel/p5-namespace-clean
+
+MAN3= Crypt::Random::Source.3 \
+ Crypt::Random::Source::Base.3 \
+ Crypt::Random::Source::Base::File.3 \
+ Crypt::Random::Source::Base::Handle.3 \
+ Crypt::Random::Source::Base::Proc.3 \
+ Crypt::Random::Source::Base::RandomDevice.3 \
+ Crypt::Random::Source::Factory.3 \
+ Crypt::Random::Source::Strong.3 \
+ Crypt::Random::Source::Strong::devrandom.3 \
+ Crypt::Random::Source::Weak.3 \
+ Crypt::Random::Source::Weak::devurandom.3 \
+ Crypt::Random::Source::Weak::rand.3
+
+PERL_CONFIGURE= yes
+
+LICENSE= ART20
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-Random-Source/distinfo b/security/p5-Crypt-Random-Source/distinfo
new file mode 100644
index 000000000000..6af21ed7aee0
--- /dev/null
+++ b/security/p5-Crypt-Random-Source/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Crypt-Random-Source-0.07.tar.gz) = bbe19a6ee24ce8d4aacbcf9179b2b3477a729eccbdfa78ad8330413b2fc3ac4f
+SIZE (Crypt-Random-Source-0.07.tar.gz) = 18883
diff --git a/security/p5-Crypt-Random-Source/pkg-descr b/security/p5-Crypt-Random-Source/pkg-descr
new file mode 100644
index 000000000000..231de3f7d6f5
--- /dev/null
+++ b/security/p5-Crypt-Random-Source/pkg-descr
@@ -0,0 +1,3 @@
+Get weak or strong random data from pluggable sources
+
+WWW: http://search.cpan.org/dist/Crypt-Random-Source
diff --git a/security/p5-Crypt-Random-Source/pkg-plist b/security/p5-Crypt-Random-Source/pkg-plist
new file mode 100644
index 000000000000..0f83a3725094
--- /dev/null
+++ b/security/p5-Crypt-Random-Source/pkg-plist
@@ -0,0 +1,22 @@
+%%SITE_PERL%%/Crypt/Random/Source.pm
+%%SITE_PERL%%/Crypt/Random/Source/Base.pm
+%%SITE_PERL%%/Crypt/Random/Source/Base/File.pm
+%%SITE_PERL%%/Crypt/Random/Source/Base/Handle.pm
+%%SITE_PERL%%/Crypt/Random/Source/Base/Proc.pm
+%%SITE_PERL%%/Crypt/Random/Source/Base/RandomDevice.pm
+%%SITE_PERL%%/Crypt/Random/Source/Factory.pm
+%%SITE_PERL%%/Crypt/Random/Source/Strong.pm
+%%SITE_PERL%%/Crypt/Random/Source/Strong/devrandom.pm
+%%SITE_PERL%%/Crypt/Random/Source/Weak.pm
+%%SITE_PERL%%/Crypt/Random/Source/Weak/devurandom.pm
+%%SITE_PERL%%/Crypt/Random/Source/Weak/rand.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/Random/Source/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/Random/Source
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/Random
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt
+@dirrm %%SITE_PERL%%/Crypt/Random/Source/Weak
+@dirrm %%SITE_PERL%%/Crypt/Random/Source/Strong
+@dirrm %%SITE_PERL%%/Crypt/Random/Source/Base
+@dirrm %%SITE_PERL%%/Crypt/Random/Source
+@dirrmtry %%SITE_PERL%%/Crypt/Random
+@dirrmtry %%SITE_PERL%%/Crypt