aboutsummaryrefslogtreecommitdiffstats
path: root/security/p5-Crypt-SaltedHash/Makefile
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2005-12-22 00:37:19 +0800
committererwin <erwin@FreeBSD.org>2005-12-22 00:37:19 +0800
commitdfb55581958eb957a4842d5e1b1cfca176c26e21 (patch)
tree111391a46639775098003362a3e0cf7fd13b9c8b /security/p5-Crypt-SaltedHash/Makefile
parent4f5d8cc3d521e96b7d8ec7ba98505eaec7096cb9 (diff)
downloadfreebsd-ports-gnome-dfb55581958eb957a4842d5e1b1cfca176c26e21.tar.gz
freebsd-ports-gnome-dfb55581958eb957a4842d5e1b1cfca176c26e21.tar.zst
freebsd-ports-gnome-dfb55581958eb957a4842d5e1b1cfca176c26e21.zip
The Crypt::SaltedHash module provides an object oriented interface to create
salted (or seeded) hashes of clear text data. The original formalization of this concept comes from RFC-3112 and is extended by the use of different digital agorithms. WWW: http://search.cpan.org/dist/Crypt-SaltedHash PR: ports/90698 Submitted by: Gabor Kovesdan
Diffstat (limited to 'security/p5-Crypt-SaltedHash/Makefile')
-rw-r--r--security/p5-Crypt-SaltedHash/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/security/p5-Crypt-SaltedHash/Makefile b/security/p5-Crypt-SaltedHash/Makefile
new file mode 100644
index 000000000000..086d4587f3d2
--- /dev/null
+++ b/security/p5-Crypt-SaltedHash/Makefile
@@ -0,0 +1,27 @@
+# New ports collection Makefile for: p5-Crypt-SaltedHash
+# Date created: 20 Dec 2006
+# Whom: Gabor Kovesdan
+# $FreeBSD$
+
+PORTNAME= Crypt-SaltedHash
+PORTVERSION= 0.03
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gkovesdan@t-hosting.hu
+COMMENT= Perl extension to work with salted hashes
+
+BUILD_DEPENDS= ${SITE_PERL}/Digest.pm:${PORTSDIR}/security/p5-Digest \
+ ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+
+PERL_CONFIGURE= yes
+
+MAN3= Crypt::SaltedHash.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>