aboutsummaryrefslogtreecommitdiffstats
path: root/security/p5-Crypt-SaltedHash
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2005-12-22 00:37:19 +0800
committererwin <erwin@FreeBSD.org>2005-12-22 00:37:19 +0800
commitdfb55581958eb957a4842d5e1b1cfca176c26e21 (patch)
tree111391a46639775098003362a3e0cf7fd13b9c8b /security/p5-Crypt-SaltedHash
parent4f5d8cc3d521e96b7d8ec7ba98505eaec7096cb9 (diff)
downloadfreebsd-ports-gnome-dfb55581958eb957a4842d5e1b1cfca176c26e21.tar.gz
freebsd-ports-gnome-dfb55581958eb957a4842d5e1b1cfca176c26e21.tar.zst
freebsd-ports-gnome-dfb55581958eb957a4842d5e1b1cfca176c26e21.zip
The Crypt::SaltedHash module provides an object oriented interface to create
salted (or seeded) hashes of clear text data. The original formalization of this concept comes from RFC-3112 and is extended by the use of different digital agorithms. WWW: http://search.cpan.org/dist/Crypt-SaltedHash PR: ports/90698 Submitted by: Gabor Kovesdan
Diffstat (limited to 'security/p5-Crypt-SaltedHash')
-rw-r--r--security/p5-Crypt-SaltedHash/Makefile27
-rw-r--r--security/p5-Crypt-SaltedHash/distinfo3
-rw-r--r--security/p5-Crypt-SaltedHash/pkg-descr6
-rw-r--r--security/p5-Crypt-SaltedHash/pkg-plist5
4 files changed, 41 insertions, 0 deletions
diff --git a/security/p5-Crypt-SaltedHash/Makefile b/security/p5-Crypt-SaltedHash/Makefile
new file mode 100644
index 000000000000..086d4587f3d2
--- /dev/null
+++ b/security/p5-Crypt-SaltedHash/Makefile
@@ -0,0 +1,27 @@
+# New ports collection Makefile for: p5-Crypt-SaltedHash
+# Date created: 20 Dec 2006
+# Whom: Gabor Kovesdan
+# $FreeBSD$
+
+PORTNAME= Crypt-SaltedHash
+PORTVERSION= 0.03
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gkovesdan@t-hosting.hu
+COMMENT= Perl extension to work with salted hashes
+
+BUILD_DEPENDS= ${SITE_PERL}/Digest.pm:${PORTSDIR}/security/p5-Digest \
+ ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+
+PERL_CONFIGURE= yes
+
+MAN3= Crypt::SaltedHash.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/security/p5-Crypt-SaltedHash/distinfo b/security/p5-Crypt-SaltedHash/distinfo
new file mode 100644
index 000000000000..fb6febff0f33
--- /dev/null
+++ b/security/p5-Crypt-SaltedHash/distinfo
@@ -0,0 +1,3 @@
+MD5 (Crypt-SaltedHash-0.03.tar.gz) = 0bfaf2c252b18bde41d970e1f3127a7f
+SHA256 (Crypt-SaltedHash-0.03.tar.gz) = 4c31654c5e85f29ea2f5d225b625081d801e36fc26ca3e14447c23f120b21df2
+SIZE (Crypt-SaltedHash-0.03.tar.gz) = 6800
diff --git a/security/p5-Crypt-SaltedHash/pkg-descr b/security/p5-Crypt-SaltedHash/pkg-descr
new file mode 100644
index 000000000000..a74004e04352
--- /dev/null
+++ b/security/p5-Crypt-SaltedHash/pkg-descr
@@ -0,0 +1,6 @@
+The Crypt::SaltedHash module provides an object oriented interface to create
+salted (or seeded) hashes of clear text data. The original formalization of
+this concept comes from RFC-3112 and is extended by the use of different
+digital agorithms.
+
+WWW: http://search.cpan.org/dist/Crypt-SaltedHash
diff --git a/security/p5-Crypt-SaltedHash/pkg-plist b/security/p5-Crypt-SaltedHash/pkg-plist
new file mode 100644
index 000000000000..5ad7b629c294
--- /dev/null
+++ b/security/p5-Crypt-SaltedHash/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Crypt/SaltedHash.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/SaltedHash/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/SaltedHash/
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Crypt 2>/dev/null || true