aboutsummaryrefslogtreecommitdiffstats
path: root/security/p5-Crypt-X509
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2005-12-22 01:38:15 +0800
committererwin <erwin@FreeBSD.org>2005-12-22 01:38:15 +0800
commit736e5299d4c724f43cba9da079883dd9522cf979 (patch)
tree976ece498029fd77930bff2317f7fc2788b61de5 /security/p5-Crypt-X509
parent1bb522c032440775db53038b63f947d4331ac03f (diff)
downloadfreebsd-ports-gnome-736e5299d4c724f43cba9da079883dd9522cf979.tar.gz
freebsd-ports-gnome-736e5299d4c724f43cba9da079883dd9522cf979.tar.zst
freebsd-ports-gnome-736e5299d4c724f43cba9da079883dd9522cf979.zip
Crypt::X509 parses X.509 certificates. Methods are provided for accessing most
certificate elements. It is based on the generic ASN.1 module by Graham Barr, on the x509decode example by Norbert Klasen and contributions on the perl-ldap-dev-Mailinglist by Chriss Ridd. WWW: http://search.cpan.org/dist/Crypt-X509 PR: ports/90716 Submitted by: Gabor Kovesdan
Diffstat (limited to 'security/p5-Crypt-X509')
-rw-r--r--security/p5-Crypt-X509/Makefile28
-rw-r--r--security/p5-Crypt-X509/distinfo3
-rw-r--r--security/p5-Crypt-X509/pkg-descr6
-rw-r--r--security/p5-Crypt-X509/pkg-plist5
4 files changed, 42 insertions, 0 deletions
diff --git a/security/p5-Crypt-X509/Makefile b/security/p5-Crypt-X509/Makefile
new file mode 100644
index 000000000000..8e3537671142
--- /dev/null
+++ b/security/p5-Crypt-X509/Makefile
@@ -0,0 +1,28 @@
+# New ports collection Makefile for: p5-Crypt-X509
+# Date created: 18 Dec 2006
+# Whom: Gabor Kovesdan
+# $FreeBSD$
+
+PORTNAME= Crypt-X509
+PORTVERSION= 0.21
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gkovesdan@t-hosting.hu
+COMMENT= Perl extension to parse X.509 certificates
+
+BUILD_DEPENDS= ${SITE_PERL}/Convert/ASN1.pm:${PORTSDIR}/converters/p5-Convert-ASN1
+
+PERL_CONFIGURE= yes
+
+MAN3= Crypt::X509.3
+
+WRKSRC= ${WRKDIR}/Crypt-X509
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/security/p5-Crypt-X509/distinfo b/security/p5-Crypt-X509/distinfo
new file mode 100644
index 000000000000..7bd82b77190c
--- /dev/null
+++ b/security/p5-Crypt-X509/distinfo
@@ -0,0 +1,3 @@
+MD5 (Crypt-X509-0.21.tar.gz) = 713b125fe8db8c2057adf3a23fb3640a
+SHA256 (Crypt-X509-0.21.tar.gz) = 8a9963280b9584078e9e422b4c7a54339dd61c8a182ccaf939798767ae70f880
+SIZE (Crypt-X509-0.21.tar.gz) = 13703
diff --git a/security/p5-Crypt-X509/pkg-descr b/security/p5-Crypt-X509/pkg-descr
new file mode 100644
index 000000000000..c2d919b6a572
--- /dev/null
+++ b/security/p5-Crypt-X509/pkg-descr
@@ -0,0 +1,6 @@
+Crypt::X509 parses X.509 certificates. Methods are provided for accessing most
+certificate elements. It is based on the generic ASN.1 module by Graham Barr,
+on the x509decode example by Norbert Klasen and contributions on the
+perl-ldap-dev-Mailinglist by Chriss Ridd.
+
+WWW: http://search.cpan.org/dist/Crypt-X509
diff --git a/security/p5-Crypt-X509/pkg-plist b/security/p5-Crypt-X509/pkg-plist
new file mode 100644
index 000000000000..bfc0e607931d
--- /dev/null
+++ b/security/p5-Crypt-X509/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Crypt/X509.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/X509/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/X509/
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Crypt 2>/dev/null || true