aboutsummaryrefslogtreecommitdiffstats
path: root/security/p5-Digest-MD5-File/Makefile
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2005-12-18 00:22:16 +0800
committererwin <erwin@FreeBSD.org>2005-12-18 00:22:16 +0800
commit23301713f0ad60443946a702571c049150e05dbf (patch)
tree48f1fc5a7a8f52aeeb1f044200dbdd64c4cf581b /security/p5-Digest-MD5-File/Makefile
parentda38219cf91bd730cf7c950e303a774d672bad5a (diff)
downloadfreebsd-ports-gnome-23301713f0ad60443946a702571c049150e05dbf.tar.gz
freebsd-ports-gnome-23301713f0ad60443946a702571c049150e05dbf.tar.zst
freebsd-ports-gnome-23301713f0ad60443946a702571c049150e05dbf.zip
Get MD5 sums for files of a given path or content of a given url.
WWW: http://search.cpan.org/dist/Digest-MD5-File PR: ports/90567 Submitted by: Gabor Kovesdan
Diffstat (limited to 'security/p5-Digest-MD5-File/Makefile')
-rw-r--r--security/p5-Digest-MD5-File/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/security/p5-Digest-MD5-File/Makefile b/security/p5-Digest-MD5-File/Makefile
new file mode 100644
index 000000000000..45994c61950f
--- /dev/null
+++ b/security/p5-Digest-MD5-File/Makefile
@@ -0,0 +1,24 @@
+# Ports collection Makefile for: p5-Digest-MD5-File
+# Date created: 17 Dec 2005
+# Whom: Gabor Kovesdan
+# $FreeBSD$
+
+PORTNAME= Digest-MD5-File
+PORTVERSION= 0.03
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Digest
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gkovesdan@t-hosting.hu
+COMMENT= Perl extension for getting MD5 sums for files and urls
+
+PERL_CONFIGURE= yes
+
+MAN3= Digest::MD5::File.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>