aboutsummaryrefslogtreecommitdiffstats
path: root/security/p5-Digest-MD5/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-06-17 10:37:15 +0800
committerwill <will@FreeBSD.org>2000-06-17 10:37:15 +0800
commit6dd7168cddcf03645b7b524d0eaec762ba4a5c26 (patch)
treedde5ee054b255f449dc09b875bfef1cb678c4d3e /security/p5-Digest-MD5/Makefile
parent09860925596143f36628cd7f462f54e90412d7ae (diff)
downloadfreebsd-ports-gnome-6dd7168cddcf03645b7b524d0eaec762ba4a5c26.tar.gz
freebsd-ports-gnome-6dd7168cddcf03645b7b524d0eaec762ba4a5c26.tar.zst
freebsd-ports-gnome-6dd7168cddcf03645b7b524d0eaec762ba4a5c26.zip
Lots and lots of cleanups. Teach p5-* in general about PKGNAMEPREFIX.
Add some missing/wrong dependencies. Show how to respect CC/CFLAGS. Many miscellaneous modifications. I used more excessive hacks to force p5-Jcode and p5-WWW-Search to respect CC/CFLAGS. Patches largely done by: Christian Weisgerber <naddy@mips.inka.de>
Diffstat (limited to 'security/p5-Digest-MD5/Makefile')
-rw-r--r--security/p5-Digest-MD5/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/security/p5-Digest-MD5/Makefile b/security/p5-Digest-MD5/Makefile
index ee62b2747cd6..47ee9f4e3fb7 100644
--- a/security/p5-Digest-MD5/Makefile
+++ b/security/p5-Digest-MD5/Makefile
@@ -5,16 +5,16 @@
# $FreeBSD$
#
-PORTNAME= p5-Digest-MD5
+PORTNAME= Digest-MD5
PORTVERSION= 2.09
CATEGORIES= security perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= MD5
-DISTNAME= Digest-MD5-2.09
+PKGNAMEPREFIX= p5-
MAINTAINER= ache@FreeBSD.org
-USE_PERL5= YES
+USE_PERL5= yes
MAN3= Digest::MD2.3 \
Digest::SHA1.3 \
@@ -29,6 +29,7 @@ MAN3= Digest::MD2.3 \
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
do-configure:
- @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
+ CC="${CC}" CCFLAGS="${CFLAGS}"
.include <bsd.port.mk>