aboutsummaryrefslogtreecommitdiffstats
path: root/security/p5-Digest-ManberHash
diff options
context:
space:
mode:
authorgabor <gabor@FreeBSD.org>2007-04-01 04:33:58 +0800
committergabor <gabor@FreeBSD.org>2007-04-01 04:33:58 +0800
commit21489a132c49b0749cfec6e3d87d3e13618455dc (patch)
tree76de47d1a9c7e85b21cbe6cf5791d3dda81c8ff2 /security/p5-Digest-ManberHash
parent97f6c457333bddd339744fd3f3f618c474266fb9 (diff)
downloadfreebsd-ports-gnome-21489a132c49b0749cfec6e3d87d3e13618455dc.tar.gz
freebsd-ports-gnome-21489a132c49b0749cfec6e3d87d3e13618455dc.tar.zst
freebsd-ports-gnome-21489a132c49b0749cfec6e3d87d3e13618455dc.zip
- Remove support for old Perl from my ports
Diffstat (limited to 'security/p5-Digest-ManberHash')
-rw-r--r--security/p5-Digest-ManberHash/Makefile11
-rw-r--r--security/p5-Digest-ManberHash/files/extrapatch-ManberHash.xs26
2 files changed, 1 insertions, 36 deletions
diff --git a/security/p5-Digest-ManberHash/Makefile b/security/p5-Digest-ManberHash/Makefile
index 2d8624a0d849..951665039d9d 100644
--- a/security/p5-Digest-ManberHash/Makefile
+++ b/security/p5-Digest-ManberHash/Makefile
@@ -17,13 +17,4 @@ PERL_CONFIGURE= yes
MAN3= Digest::ManberHash.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-EXTRA_PATCHES= ${PATCHDIR}/extrapatch-ManberHash.xs
-
-post-patch:
- ${PERL} -pi -e 's/^our\s+([\$$\@\%]\w+)/use vars qw($$1); $$1/;' ${WRKSRC}/ManberHash.pm
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/p5-Digest-ManberHash/files/extrapatch-ManberHash.xs b/security/p5-Digest-ManberHash/files/extrapatch-ManberHash.xs
deleted file mode 100644
index 930e09254f4f..000000000000
--- a/security/p5-Digest-ManberHash/files/extrapatch-ManberHash.xs
+++ /dev/null
@@ -1,26 +0,0 @@
---- ManberHash.xs.orig Sat Dec 24 11:04:38 2005
-+++ ManberHash.xs Sat Dec 24 11:04:06 2005
-@@ -3,6 +3,14 @@
- #include "perl.h"
- #include "XSUB.h"
-
-+/* try to be compatible with older perls */
-+/* SvPV_nolen() macro first defined in 5.005_55 */
-+/* this is slow, not threadsafe, but works */
-+#include "patchlevel.h"
-+#if (PATCHLEVEL == 4) || ((PATCHLEVEL == 5) && (SUBVERSION < 55))
-+static STRLEN nolen_na;
-+# define SvPV_nolen(sv) SvPV ((sv), nolen_na)
-+#endif
-
- #define BUFFER_SIZE (8192)
- #define BUFFER_2SIZE (BUFFER_SIZE*2)
-@@ -105,7 +113,7 @@
- }
- */
-
-- fh=open(filename,O_RDONLY);
-+ fh=open(filename,0000);
- if (fh<0)
- return;
-