aboutsummaryrefslogtreecommitdiffstats
path: root/security/p5-Digest-Nilsimsa/Makefile
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2002-08-16 00:34:52 +0800
committerleeym <leeym@FreeBSD.org>2002-08-16 00:34:52 +0800
commita089b4789b732600578fdcac05ee3e10bd57cac1 (patch)
treee80d92744891a016866e81514c75dbba5589af47 /security/p5-Digest-Nilsimsa/Makefile
parent16bd96bf7bdc55b53184ccdacb00738060a1ebb1 (diff)
downloadfreebsd-ports-gnome-a089b4789b732600578fdcac05ee3e10bd57cac1.tar.gz
freebsd-ports-gnome-a089b4789b732600578fdcac05ee3e10bd57cac1.tar.zst
freebsd-ports-gnome-a089b4789b732600578fdcac05ee3e10bd57cac1.zip
new port: security/p5-Digest-Nilsimsa
A nilsimsa signature is a statistic of n-gram occurance in a piece of text. It is a 256 bit value usually represented in hex. This module is a wrapper around nilsimsa implementation in C by cmeclax. PR: ports/41644 Submitted by: Yen-Ming Lee <leeym@utopia.leeym.com>
Diffstat (limited to 'security/p5-Digest-Nilsimsa/Makefile')
-rw-r--r--security/p5-Digest-Nilsimsa/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/security/p5-Digest-Nilsimsa/Makefile b/security/p5-Digest-Nilsimsa/Makefile
new file mode 100644
index 000000000000..89a531410a24
--- /dev/null
+++ b/security/p5-Digest-Nilsimsa/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Digest-Nilsimsa
+# Date created: 13 August 2002
+# Whom: Yen-Ming Lee <leeym@leeym.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Digest-Nilsimsa
+PORTVERSION= 0.06
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Digest
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= leeym@leeym.com
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Digest::Nilsimsa.3
+
+.include <bsd.port.mk>