aboutsummaryrefslogtreecommitdiffstats
path: root/security/p5-Digest-SHA256
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2006-03-24 00:13:07 +0800
committertobez <tobez@FreeBSD.org>2006-03-24 00:13:07 +0800
commit890755675ebb4848ea624c8e901a5188e13b0567 (patch)
tree9730710673dedb77373e7de569a46b1823301b48 /security/p5-Digest-SHA256
parent612260ba420241f8e52249cd512f964ae5196c77 (diff)
downloadfreebsd-ports-gnome-890755675ebb4848ea624c8e901a5188e13b0567.tar.gz
freebsd-ports-gnome-890755675ebb4848ea624c8e901a5188e13b0567.tar.zst
freebsd-ports-gnome-890755675ebb4848ea624c8e901a5188e13b0567.zip
Fix byteorder determination, which led to the digest being computed
incorrectly. PR: 92014 Reported by: Johan van Selst <johans@stack.nl> Approved by: maintainer timeout (>>2 weeks)
Diffstat (limited to 'security/p5-Digest-SHA256')
-rw-r--r--security/p5-Digest-SHA256/Makefile1
-rw-r--r--security/p5-Digest-SHA256/files/patch-Makefile.PL22
2 files changed, 23 insertions, 0 deletions
diff --git a/security/p5-Digest-SHA256/Makefile b/security/p5-Digest-SHA256/Makefile
index 01f2b0e7e51c..34479e5d05a0 100644
--- a/security/p5-Digest-SHA256/Makefile
+++ b/security/p5-Digest-SHA256/Makefile
@@ -10,6 +10,7 @@
PORTNAME= Digest-SHA256
PORTVERSION= 0.01b
+PORTREVISION= 1
CATEGORIES= security perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Digest
diff --git a/security/p5-Digest-SHA256/files/patch-Makefile.PL b/security/p5-Digest-SHA256/files/patch-Makefile.PL
new file mode 100644
index 000000000000..863c37335fee
--- /dev/null
+++ b/security/p5-Digest-SHA256/files/patch-Makefile.PL
@@ -0,0 +1,22 @@
+--- Makefile.PL Mon Mar 12 06:19:07 2001
++++ Makefile.PL Fri Jan 20 14:23:20 2006
+@@ -9,6 +9,10 @@ WriteMakefile(
+ );
+
+ if (exists($Config{'byteorder'}) and defined($Config{'byteorder'})) {
++ my $bo = $Config{'byteorder'};
++ if (length($bo) == 8 && $Config{use64bitint} && !$Config{use64bitall}) {
++ $bo =~ s/[5678]//g;
++ }
+ if (-e 'endian.h') {
+ warn "Warning: overwriting endian.h\n";
+ } else {
+@@ -24,7 +28,7 @@ if (exists($Config{'byteorder'}) and def
+
+ /* Warning! this file is automatically generated; changes WILL disappear */
+
+-#define BYTEORDER $Config{'byteorder'}
++#define BYTEORDER $bo
+
+ #endif /* ENDIAN_H */
+ END_OF_STRING