aboutsummaryrefslogtreecommitdiffstats
path: root/security/p5-POE-Component-SSLify
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2005-10-12 19:41:16 +0800
committerskv <skv@FreeBSD.org>2005-10-12 19:41:16 +0800
commit119908d8564e4e6b20d8388ae05846bf1aff06b8 (patch)
tree535ed9bbe142d1ba57418ab124f8f1a6f2010bb6 /security/p5-POE-Component-SSLify
parentd98a36e137b85edfdfe7a53a884538ba517feb08 (diff)
downloadfreebsd-ports-gnome-119908d8564e4e6b20d8388ae05846bf1aff06b8.tar.gz
freebsd-ports-gnome-119908d8564e4e6b20d8388ae05846bf1aff06b8.tar.zst
freebsd-ports-gnome-119908d8564e4e6b20d8388ae05846bf1aff06b8.zip
Fix build on perl < 5.6
PR: ports/87315 Submitted by: lth
Diffstat (limited to 'security/p5-POE-Component-SSLify')
-rw-r--r--security/p5-POE-Component-SSLify/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/security/p5-POE-Component-SSLify/Makefile b/security/p5-POE-Component-SSLify/Makefile
index cabaea3f53af..ab996c0d043f 100644
--- a/security/p5-POE-Component-SSLify/Makefile
+++ b/security/p5-POE-Component-SSLify/Makefile
@@ -24,4 +24,11 @@ MAN3= POE::Component::SSLify.3 \
POE::Component::SSLify::ClientHandle.3 \
POE::Component::SSLify::ServerHandle.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500600
+post-patch:
+ @${PERL} -pi -e 's/^our (%\w+)/use vars qw($$1); $$1/;' \
+ -e '$$_ = "" if /use warnings/;' \
+ $$(${FIND} ${WRKSRC} -name '*.pm')
+.endif
+.include <bsd.port.post.mk>