aboutsummaryrefslogtreecommitdiffstats
path: root/security/p5-SAVI-Perl
diff options
context:
space:
mode:
authorniels <niels@FreeBSD.org>2005-01-14 22:04:38 +0800
committerniels <niels@FreeBSD.org>2005-01-14 22:04:38 +0800
commit1a428940d566a64112b9aa4731c9329762218f6c (patch)
tree27b7cc4d41d73d4b73fb80045620de60b951b3b8 /security/p5-SAVI-Perl
parenta6e47e282f919dc4b0fcb87d5c9cd4407ccdf867 (diff)
downloadfreebsd-ports-gnome-1a428940d566a64112b9aa4731c9329762218f6c.tar.gz
freebsd-ports-gnome-1a428940d566a64112b9aa4731c9329762218f6c.tar.zst
freebsd-ports-gnome-1a428940d566a64112b9aa4731c9329762218f6c.zip
Fixed build error that occurs when libsavi is installed and added
ONLY_FOR_ARCHS since this port is for i386 only (reported by Kris) Approved by: nectar (mentor), maintainer
Diffstat (limited to 'security/p5-SAVI-Perl')
-rw-r--r--security/p5-SAVI-Perl/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/security/p5-SAVI-Perl/Makefile b/security/p5-SAVI-Perl/Makefile
index 60b03fb7d3de..756e342abead 100644
--- a/security/p5-SAVI-Perl/Makefile
+++ b/security/p5-SAVI-Perl/Makefile
@@ -6,6 +6,7 @@
PORTNAME= SAVI-Perl
PORTVERSION= 0.30
+PORTREVISION= 1
CATEGORIES= security perl5
MASTER_SITES= http://www.csupomona.edu/~henson/www/projects/SAVI-Perl/dist/
MASTER_SITE_SUBDIR= security
@@ -17,6 +18,7 @@ COMMENT= Perl5 module interface to Sophos AntiVirus
MAN= SAVI.3
PERL_CONFIGURE= yes
+ONLY_FOR_ARCHS= i386
.include <bsd.port.pre.mk>
@@ -26,4 +28,15 @@ IGNORE= Port requires perl 5.6 or newer. Upgrade your perl and try again. \
yet.
.endif
+.if exists(${PREFIX}/lib/libsavi.so.3) && !exists(${PREFIX}/lib/libsavi.so)
+FAKELIBDIR=${WRKDIR}/lib
+CONFIGURE_ARGS+= LDDLFLAGS='-shared -L ${FAKELIBDIR}'
+.endif
+
+.if defined(FAKELIBDIR)
+pre-configure:
+ ${MKDIR} ${FAKELIBDIR}
+ ${LN} -s ${PREFIX}/lib/libsavi.so.3 ${FAKELIBDIR}/libsavi.so
+.endif
+
.include <bsd.port.post.mk>