aboutsummaryrefslogtreecommitdiffstats
path: root/security/p5-openxpki
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-09-10 02:20:00 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-09-10 02:20:00 +0800
commit74ca94454226f479dfab8b57ca33253f1d8e30a4 (patch)
treee6374528c73d51ed756db062ee55eac415dc20c7 /security/p5-openxpki
parentb4d32943e78d39b6274a1d2cf4b4276818636f4c (diff)
downloadfreebsd-ports-gnome-74ca94454226f479dfab8b57ca33253f1d8e30a4.tar.gz
freebsd-ports-gnome-74ca94454226f479dfab8b57ca33253f1d8e30a4.tar.zst
freebsd-ports-gnome-74ca94454226f479dfab8b57ca33253f1d8e30a4.zip
- Update OSVERSION check and comment
- While I'm here: - Move LICENSE upward - Use USES=gmake - Convert to new perl5 framework - Fix spelling of FreeBSD and OpenSSL - Remove outdated OSVERSION check PR: ports/181828 Submitted by: Sergei Vyshenski <svysh.fbsd@gmail.com> (maintainer)
Diffstat (limited to 'security/p5-openxpki')
-rw-r--r--security/p5-openxpki/Makefile33
1 files changed, 15 insertions, 18 deletions
diff --git a/security/p5-openxpki/Makefile b/security/p5-openxpki/Makefile
index 25f4c988e1f6..c644f1834878 100644
--- a/security/p5-openxpki/Makefile
+++ b/security/p5-openxpki/Makefile
@@ -13,6 +13,8 @@ DIST_SUBDIR= openxpki
MAINTAINER= svysh.fbsd@gmail.com
COMMENT= Perl based trustcenter software for PKI: core for server
+LICENSE= ART20
+
BUILD_DEPENDS= \
p5-Workflow>=0.31:${PORTSDIR}/devel/p5-Workflow \
p5-CGI-Session>=0:${PORTSDIR}/www/p5-CGI-Session \
@@ -279,15 +281,14 @@ MAN3= OpenXPKI.3 \
OpenXPKI::XML::Cache.3 \
OpenXPKI::XML::Config.3 \
OpenXPKI::i18n.3
-USE_GMAKE= yes
USE_OPENSSL= yes
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= gmake perl5
+WITH_OPENSSL_BASE= yes
USERS= openxpki
GROUPS= openxpki
-LICENSE= ART20
-
OPTIONS_DEFINE= DEVELOPER GRAPHVIZ
DEVELOPER_DESC= Install development tools for OpenXPKI?
GRAPHVIZ_DESC= With graphical visualization of workflows?
@@ -300,20 +301,6 @@ GRAPHVIZ_DESC= With graphical visualization of workflows?
.include <bsd.port.options.mk>
-# this port needs openssl-0.9.8+, but does not yet compile with openssl-1.0.0+
-# freebsd-6 or less has base openssl-0.9.7 which is bad
-# freebsd-7 or more has base openssl-0.9.8 which is good
-# openssl from port now has version 1.0.0 only
-.if ${OSVERSION} < 700000
-IGNORE= needs openssl-0.9.8+, but does not yet compile with openssl-1.0.0+
-.endif
-.if ${OSVERSION} >= 700000
-WITH_OPENSSL_BASE= yes
-
-.endif
-
-.include <bsd.port.pre.mk>
-
.if ${PORT_OPTIONS:MDEVELOPER}
RUN_DEPENDS+= ${LOCALBASE}/bin/fop:${PORTSDIR}/textproc/fop \
${LOCALBASE}/bin/xsltproc:${PORTSDIR}/textproc/libxslt \
@@ -325,4 +312,14 @@ RUN_DEPENDS+= ${LOCALBASE}/bin/dot:${PORTSDIR}/graphics/graphviz \
${LOCALBASE}/bin/imgsize:${PORTSDIR}/graphics/p5-Image-Size
.endif
+.include <bsd.port.pre.mk>
+
+# this port needs OpenSSL 0.9.8+, but does not yet compile with OpenSSL 1.0.0+
+# FreeBSD 7,8,9 have base OpenSSL 0.9.8 which is good
+# FreeBSD 10 has base OpenSSL 1.0+ which is bad
+# OpenSSL from port now has version 1.0+ only
+.if ${OSVERSION} >= 1000000
+IGNORE= needs OpenSSL 0.9.8+, but does not yet compile with OpenSSL 1.0.0+
+.endif
+
.include <bsd.port.post.mk>