aboutsummaryrefslogtreecommitdiffstats
path: root/security/pad/Makefile
diff options
context:
space:
mode:
authornbm <nbm@FreeBSD.org>2000-09-24 02:25:22 +0800
committernbm <nbm@FreeBSD.org>2000-09-24 02:25:22 +0800
commit4acce3bb13d86bee0d5b7f061cd5c6e3e237bf5f (patch)
tree7c274b228af28742c2e56e3e7060a1501ead4e15 /security/pad/Makefile
parent58343030028465a60485743b6048765665875703 (diff)
downloadfreebsd-ports-gnome-4acce3bb13d86bee0d5b7f061cd5c6e3e237bf5f.tar.gz
freebsd-ports-gnome-4acce3bb13d86bee0d5b7f061cd5c6e3e237bf5f.tar.zst
freebsd-ports-gnome-4acce3bb13d86bee0d5b7f061cd5c6e3e237bf5f.zip
Update to 0.7.
PR: 21503 Submitted by: Trevor Johnson <trevor@jpj.net> (maintainer)
Diffstat (limited to 'security/pad/Makefile')
-rw-r--r--security/pad/Makefile20
1 files changed, 8 insertions, 12 deletions
diff --git a/security/pad/Makefile b/security/pad/Makefile
index b627f584b6a7..b309e5f30dc8 100644
--- a/security/pad/Makefile
+++ b/security/pad/Makefile
@@ -6,27 +6,23 @@
#
PORTNAME= pad
-PORTVERSION= 0.5
+PORTVERSION= 0.7
CATEGORIES= security
MASTER_SITES= http://www.lammah.com/pad/
EXTRACT_SUFX= .tgz
MAINTAINER= trevor@jpj.net
-post-extract:
- @${RM} ${WRKSRC}/install-sh ${WRKSRC}/mkinstalldirs \
- ${WRKSRC}/missing ${WRKSRC}/INSTALL ${WRKSRC}/COPYING
- @${TOUCH} ${WRKSRC}/install-sh ${WRKSRC}/mkinstalldirs \
- ${WRKSRC}/missing ${WRKSRC}/INSTALL ${WRKSRC}/COPYING
-
+DOC_FILES= COPYING README ChangeLog
GNU_CONFIGURE= yes
-USE_AUTOMAKE= yes
-USE_GMAKE= yes
-post-install:
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/pad ${PREFIX}/bin
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/pad
- @${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/pad
+ ${MKDIR} ${PREFIX}/share/doc/pad
+.for i in ${DOC_FILES}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${PREFIX}/share/doc/pad
+.endfor
.endif
.include <bsd.port.mk>