aboutsummaryrefslogtreecommitdiffstats
path: root/security/pam_af
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2006-10-02 04:05:53 +0800
committerstas <stas@FreeBSD.org>2006-10-02 04:05:53 +0800
commitb9388dc46b6860894e5ec6e3a6e88296198c0602 (patch)
treec89bdfd56013f0dc28efc166ebc52739b991eacb /security/pam_af
parent8d7bfd5331103feaf12a32eafb9d89503e3a4815 (diff)
downloadfreebsd-ports-gnome-b9388dc46b6860894e5ec6e3a6e88296198c0602.tar.gz
freebsd-ports-gnome-b9388dc46b6860894e5ec6e3a6e88296198c0602.tar.zst
freebsd-ports-gnome-b9388dc46b6860894e5ec6e3a6e88296198c0602.zip
- Fix compiling with oncoming gcc41.
Reported by: pointyhat run Approved by: sem (mentor)
Diffstat (limited to 'security/pam_af')
-rw-r--r--security/pam_af/Makefile2
-rw-r--r--security/pam_af/files/patch-common_subr.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/security/pam_af/Makefile b/security/pam_af/Makefile
index 70556ad8e89e..a5883cc55585 100644
--- a/security/pam_af/Makefile
+++ b/security/pam_af/Makefile
@@ -10,7 +10,7 @@ PORTVERSION= 1.0
CATEGORIES= security
MASTER_SITES= http://mbsd.msk.ru/dist/
-MAINTAINER= ssedov@mbsd.msk.ru
+MAINTAINER= stas@FreeBSD.org
COMMENT= Anti-bruteforce PAM module
USE_BZIP2= yes
diff --git a/security/pam_af/files/patch-common_subr.c b/security/pam_af/files/patch-common_subr.c
new file mode 100644
index 000000000000..807db943817d
--- /dev/null
+++ b/security/pam_af/files/patch-common_subr.c
@@ -0,0 +1,11 @@
+--- common/subr.c.orig Sun Oct 1 18:13:16 2006
++++ common/subr.c Sun Oct 1 18:14:09 2006
+@@ -322,7 +322,7 @@
+ const char *db;
+ char *host;
+ {
+- datum key, data;
++ datum key, data = {NULL, 0};
+ struct myaddrinfo *res0, *res;
+ static hostrule_t hstent;
+ int found = 0;