aboutsummaryrefslogtreecommitdiffstats
path: root/security/pam_mkhomedir
diff options
context:
space:
mode:
authorniels <niels@FreeBSD.org>2005-06-15 04:01:55 +0800
committerniels <niels@FreeBSD.org>2005-06-15 04:01:55 +0800
commit9731ff7621728a994babbbfb73b940a796491a2f (patch)
tree9c937c681081c1a9f58fc1bfb07f961b012a4692 /security/pam_mkhomedir
parentb73bbaef483b7822752216cc964006411a49c48b (diff)
downloadfreebsd-ports-gnome-9731ff7621728a994babbbfb73b940a796491a2f.tar.gz
freebsd-ports-gnome-9731ff7621728a994babbbfb73b940a796491a2f.tar.zst
freebsd-ports-gnome-9731ff7621728a994babbbfb73b940a796491a2f.zip
New port: Create HOME directory with a PAM module on demand
Based on submission via the following PR: PR: ports/82032 Submitted by: Martin Mersberger Approved by: nectar (mentor)
Diffstat (limited to 'security/pam_mkhomedir')
-rw-r--r--security/pam_mkhomedir/Makefile56
-rw-r--r--security/pam_mkhomedir/distinfo2
-rw-r--r--security/pam_mkhomedir/files/pkg-message.in9
-rw-r--r--security/pam_mkhomedir/pkg-descr4
-rw-r--r--security/pam_mkhomedir/pkg-plist4
5 files changed, 75 insertions, 0 deletions
diff --git a/security/pam_mkhomedir/Makefile b/security/pam_mkhomedir/Makefile
new file mode 100644
index 000000000000..e3160a00ac61
--- /dev/null
+++ b/security/pam_mkhomedir/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: pam_mkhomedir
+# Date created: 08 June 2005
+# Whom: Martin Mersberger
+#
+# $FreeBSD$
+#
+
+PORTNAME= pam_mkhomedir
+PORTVERSION= 0.1
+CATEGORIES= security
+MASTER_SITES= http://portal-to-web.de/pam_mkhomedir/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Create HOME with a PAM module on demand
+
+MANCOMPRESSED= yes
+MAN8= pam_mkhomedir.8
+SUB_FILES= pkg-message
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= Only for 5.0 and above
+.endif
+
+.if defined(WITH_PROFILE)
+PLIST_SUB+= PROFILE=""
+MAKE_ARGS+= PROFILE=yes
+WITH_STATIC= yes
+.else
+PLIST_SUB+= PROFILE="@comment "
+.endif
+
+.if defined(WITH_STATIC)
+PLIST_SUB+= NOSTATIC=""
+.else
+MAKE_ARGS+= NOINSTALLLIB=yes
+PLIST_SUB+= NOSTATIC="@comment "
+.endif
+
+pre-everything::
+
+.if !defined(WITH_PROFILE) || !defined(WITH_STATIC)
+ @${ECHO_CMD} ""
+ @${ECHO_CMD} "All definable build options"
+ @${ECHO_CMD} "---------------------------"
+ @${ECHO_CMD} ""
+ @${ECHO_CMD} "WITH_PROFILE=yes Build with static lib with profile"
+ @${ECHO_CMD} "WITH_STATIC=yes Build with static lib"
+ @${ECHO_CMD} ""
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/security/pam_mkhomedir/distinfo b/security/pam_mkhomedir/distinfo
new file mode 100644
index 000000000000..cdd5811489e4
--- /dev/null
+++ b/security/pam_mkhomedir/distinfo
@@ -0,0 +1,2 @@
+MD5 (pam_mkhomedir-0.1.tar.gz) = 41109fe6b913d2909ece167afdc47bbd
+SIZE (pam_mkhomedir-0.1.tar.gz) = 5438
diff --git a/security/pam_mkhomedir/files/pkg-message.in b/security/pam_mkhomedir/files/pkg-message.in
new file mode 100644
index 000000000000..11743e4057a0
--- /dev/null
+++ b/security/pam_mkhomedir/files/pkg-message.in
@@ -0,0 +1,9 @@
+
+You may want to add something like this to your /etc/pam.d/login
+or /etc/pam.d/sshd ( when you've configured ssh with PAM )
+file to use this module:
+
+session required %%PREFIX%%/lib/pam_mkhomedir.so
+
+
+
diff --git a/security/pam_mkhomedir/pkg-descr b/security/pam_mkhomedir/pkg-descr
new file mode 100644
index 000000000000..ab5b5d8b7f09
--- /dev/null
+++ b/security/pam_mkhomedir/pkg-descr
@@ -0,0 +1,4 @@
+This is a PAM module which will create the $HOME for the user authenticated,
+if it's not already there. It also copies over files from a skel directory
+( default /usr/share/skel ) and can set the permission of the newly created
+$HOME to a value of your choice
diff --git a/security/pam_mkhomedir/pkg-plist b/security/pam_mkhomedir/pkg-plist
new file mode 100644
index 000000000000..1f180132cf16
--- /dev/null
+++ b/security/pam_mkhomedir/pkg-plist
@@ -0,0 +1,4 @@
+%%NOSTATIC%%lib/libpam_mkhomedir.a
+%%PROFILE%%lib/libpam_mkhomedir_p.a
+lib/pam_mkhomedir.so
+lib/pam_mkhomedir.so.2