aboutsummaryrefslogtreecommitdiffstats
path: root/security/paperkey
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2008-10-06 22:09:46 +0800
committerroam <roam@FreeBSD.org>2008-10-06 22:09:46 +0800
commit9d30b1e108f53f560d847350054306cc4b6cdd83 (patch)
tree2f5c9c131e931998ea0050cc95aa464b59913038 /security/paperkey
parentcdc88f59fcad86678fb6ba588bb3465fcd3c1d3d (diff)
downloadfreebsd-ports-gnome-9d30b1e108f53f560d847350054306cc4b6cdd83.tar.gz
freebsd-ports-gnome-9d30b1e108f53f560d847350054306cc4b6cdd83.tar.zst
freebsd-ports-gnome-9d30b1e108f53f560d847350054306cc4b6cdd83.zip
Initial import of paperkey-0.8, a simple tool for extracting the truly
secret parts of a PGP secret key for backup purposes. Obtained from: http://www.jabberwocky.com/software/paperkey/ Author: David Shaw <dshaw@jabberwocky.com>
Diffstat (limited to 'security/paperkey')
-rw-r--r--security/paperkey/Makefile30
-rw-r--r--security/paperkey/distinfo3
-rw-r--r--security/paperkey/pkg-descr8
-rw-r--r--security/paperkey/pkg-plist4
4 files changed, 45 insertions, 0 deletions
diff --git a/security/paperkey/Makefile b/security/paperkey/Makefile
new file mode 100644
index 000000000000..a909c9a5b567
--- /dev/null
+++ b/security/paperkey/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: paperkey
+# Date created: Mon Oct 6 12:56:53 EEST 2008
+# Whom: Peter Pentchev <roam@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= paperkey
+PORTVERSION= 0.8
+CATEGORIES= security
+MASTER_SITES= http://www.jabberwocky.com/software/paperkey/
+
+MAINTAINER= roam@FreeBSD.org
+COMMENT= Extract just the secret information out of OpenPGP secret keys
+
+GNU_CONFIGURE= yes
+ALL_TARGET= all check
+
+MAN1= paperkey.1
+
+post-patch:
+ ${REINPLACE_CMD} -e 's@/usr/share/doc/paperkey/README.gz@${DOCSDIR}/README@' ${WRKSRC}/paperkey.1
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/NEWS ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/paperkey/distinfo b/security/paperkey/distinfo
new file mode 100644
index 000000000000..0470f46c78d4
--- /dev/null
+++ b/security/paperkey/distinfo
@@ -0,0 +1,3 @@
+MD5 (paperkey-0.8.tar.gz) = e80b54ef333dcb7acf2c98e19b016b24
+SHA256 (paperkey-0.8.tar.gz) = 72f0f453937bfb480573fd8cca49b8967d59adcc6b2626c5339748ed93f6315c
+SIZE (paperkey-0.8.tar.gz) = 157181
diff --git a/security/paperkey/pkg-descr b/security/paperkey/pkg-descr
new file mode 100644
index 000000000000..c7aa3463b60e
--- /dev/null
+++ b/security/paperkey/pkg-descr
@@ -0,0 +1,8 @@
+From the paperkey README file:
+ A reasonable way to achieve a long term backup of OpenPGP (GnuPG, PGP,
+ etc) keys is to print them out on paper. Paper and ink have amazingly
+ long retention qualities - far longer than the magnetic or optical
+ means that are generally used to back up computer data.
+
+WWW: http://www.jabberwocky.com/software/paperkey/
+Author: David Shaw <dshaw@jabberwocky.com>
diff --git a/security/paperkey/pkg-plist b/security/paperkey/pkg-plist
new file mode 100644
index 000000000000..0204e355a43d
--- /dev/null
+++ b/security/paperkey/pkg-plist
@@ -0,0 +1,4 @@
+bin/paperkey
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%