aboutsummaryrefslogtreecommitdiffstats
path: root/security/pear-Auth_OpenID
diff options
context:
space:
mode:
authormm <mm@FreeBSD.org>2008-10-02 23:51:29 +0800
committermm <mm@FreeBSD.org>2008-10-02 23:51:29 +0800
commit023c5c1bacb3f11bc57918766c4bc7248c77d6e4 (patch)
treec062f75916ca49267aa520a0c9752278b4fdf034 /security/pear-Auth_OpenID
parent4fb5c7c3d9b2c3bcdd3973b7001e181a586acd75 (diff)
downloadfreebsd-ports-gnome-023c5c1bacb3f11bc57918766c4bc7248c77d6e4.tar.gz
freebsd-ports-gnome-023c5c1bacb3f11bc57918766c4bc7248c77d6e4.tar.zst
freebsd-ports-gnome-023c5c1bacb3f11bc57918766c4bc7248c77d6e4.zip
- Update to 2.1.2
- Add option for PEAR_DB
Diffstat (limited to 'security/pear-Auth_OpenID')
-rw-r--r--security/pear-Auth_OpenID/Makefile19
-rw-r--r--security/pear-Auth_OpenID/distinfo6
2 files changed, 17 insertions, 8 deletions
diff --git a/security/pear-Auth_OpenID/Makefile b/security/pear-Auth_OpenID/Makefile
index 84dbb4d7126d..d33ec58c3f1a 100644
--- a/security/pear-Auth_OpenID/Makefile
+++ b/security/pear-Auth_OpenID/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Auth_OpenID
-PORTVERSION= 2.0.1
+PORTVERSION= 2.1.2
CATEGORIES= security www pear
MASTER_SITES= http://openidenabled.com/files/php-openid/packages/
DISTNAME= php-openid-${PORTVERSION}
@@ -24,7 +24,8 @@ LATEST_LINK= pear-Auth_OpenID
WRKSRC= ${WRKDIR}/php-openid-${PORTVERSION}
-OPTIONS= BCMATH "Use bcmath instead of libgmp" off
+OPTIONS= BCMATH "Use bcmath instead of libgmp" off \
+ PEAR_DB "Support SQL stores" off
USE_PHP= curl dom
USE_PYTHON_BUILD= yes
@@ -35,8 +36,9 @@ FILES= Auth/OpenID.php Auth/OpenID/AX.php \
Auth/OpenID/DatabaseConnection.php \
Auth/OpenID/DiffieHellman.php Auth/OpenID/Discover.php \
Auth/OpenID/DumbStore.php Auth/OpenID/Extension.php \
- Auth/OpenID/FileStore.php Auth/OpenID/HMACSHA1.php \
+ Auth/OpenID/FileStore.php Auth/OpenID/HMAC.php \
Auth/OpenID/Interface.php Auth/OpenID/KVForm.php \
+ Auth/OpenID/MemcachedStore.php \
Auth/OpenID/Message.php Auth/OpenID/MySQLStore.php \
Auth/OpenID/Nonce.php Auth/OpenID/PAPE.php \
Auth/OpenID/Parse.php Auth/OpenID/PostgreSQLStore.php \
@@ -84,6 +86,7 @@ DOCS= OpenID/Auth_OpenID_AX.html \
OpenID/Auth_OpenID_MalformedReturnURL.html \
OpenID/Auth_OpenID_MalformedTrustRoot.html \
OpenID/Auth_OpenID_Mapping.html \
+ OpenID/Auth_OpenID_MemcachedStore.html \
OpenID/Auth_OpenID_Message.html \
OpenID/Auth_OpenID_MySQLStore.html \
OpenID/Auth_OpenID_NamespaceMap.html \
@@ -134,6 +137,7 @@ DOCS= OpenID/Auth_OpenID_AX.html \
OpenID/_Auth---OpenID---Extension.php.html \
OpenID/_Auth---OpenID---FileStore.php.html \
OpenID/_Auth---OpenID---Interface.php.html \
+ OpenID/_Auth---OpenID---MemcachedStore.php.html \
OpenID/_Auth---OpenID---Message.php.html \
OpenID/_Auth---OpenID---MySQLStore.php.html \
OpenID/_Auth---OpenID---Nonce.php.html \
@@ -156,8 +160,8 @@ DOCS= OpenID/Auth_OpenID_AX.html \
media/banner.css media/stylesheet.css
EXAMPLES= README consumer/common.php consumer/finish_auth.php \
- consumer/index.php consumer/try_auth.php \
- detect.php server/index.php server/lib/actions.php \
+ consumer/index.php consumer/try_auth.php detect.php \
+ discover.php server/index.php server/lib/actions.php \
server/lib/common.php server/lib/render.php \
server/lib/render/about.php server/lib/render/idpXrds.php \
server/lib/render/idpage.php server/lib/render/login.php \
@@ -177,6 +181,11 @@ USE_PHP+= bcmath
USE_PHP+= gmp
.endif
+.ifdef(WITH_PEAR_DB)
+BUILD_DEPENDS+= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
+RUN_DEPENDS+= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
+.endif
+
post-configure:
@cd ${WRKSRC}/admin && ${PYTHON_CMD} packagexml.py ${PORTVERSION} package2.xml ../CHANGELOG > ${WRKDIR}/package.xml
diff --git a/security/pear-Auth_OpenID/distinfo b/security/pear-Auth_OpenID/distinfo
index 325ba46a85e3..a32284f706ce 100644
--- a/security/pear-Auth_OpenID/distinfo
+++ b/security/pear-Auth_OpenID/distinfo
@@ -1,3 +1,3 @@
-MD5 (PEAR/php-openid-2.0.1.tar.bz2) = e8be2d48139b4faa45626661c329bdb2
-SHA256 (PEAR/php-openid-2.0.1.tar.bz2) = db73c30924067c8388662f734a814e8c7256681906e69658d98fb118ef2aa241
-SIZE (PEAR/php-openid-2.0.1.tar.bz2) = 298646
+MD5 (PEAR/php-openid-2.1.2.tar.bz2) = 26b96fa2cfa18e7ebc4532bafe6e75c2
+SHA256 (PEAR/php-openid-2.1.2.tar.bz2) = bb6281b7926e66d201df55fd424d10660f6aa45406b0e1791093e065feb48204
+SIZE (PEAR/php-openid-2.1.2.tar.bz2) = 311216