aboutsummaryrefslogtreecommitdiffstats
path: root/security/pecl-scrypt
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2014-03-18 22:32:15 +0800
committerswills <swills@FreeBSD.org>2014-03-18 22:32:15 +0800
commitf63da90f74b0aabe4171cb57e32a4754a6cf0c77 (patch)
tree5a970e450ae1f3b5ae9f3d6644a7425803d44d96 /security/pecl-scrypt
parenta4ae9720900c54b7c25b4cc247810e1a5108f871 (diff)
downloadfreebsd-ports-gnome-f63da90f74b0aabe4171cb57e32a4754a6cf0c77.tar.gz
freebsd-ports-gnome-f63da90f74b0aabe4171cb57e32a4754a6cf0c77.tar.zst
freebsd-ports-gnome-f63da90f74b0aabe4171cb57e32a4754a6cf0c77.zip
- Change License from BSD to BSD2CLAUSE
- Add USES=compiler, REINPLACE is only needed for gcc - Add DOCS to Options - Add DOCSDIR - Add BUFFER_OVERFLOW_PROTECTION to Options - Strip library - Bump PORTREVISION PR: ports/187669 Submitted by: Horia Racoviceanu <horia@racoviceanu.com> (maintainer)
Diffstat (limited to 'security/pecl-scrypt')
-rw-r--r--security/pecl-scrypt/Makefile27
1 files changed, 25 insertions, 2 deletions
diff --git a/security/pecl-scrypt/Makefile b/security/pecl-scrypt/Makefile
index a57ade19685c..b45879094892 100644
--- a/security/pecl-scrypt/Makefile
+++ b/security/pecl-scrypt/Makefile
@@ -3,6 +3,7 @@
PORTNAME= scrypt
PORTVERSION= 1.2
+PORTREVISION= 1
CATEGORIES= security pear
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
@@ -11,17 +12,39 @@ EXTRACT_SUFX= .tgz
MAINTAINER= horia@racoviceanu.com
COMMENT= PHP wrapper to Colin Percival's scrypt implementation
-LICENSE= BSD
+LICENSE= BSD2CLAUSE
+USES= compiler
USE_PHP= hash
USE_PHPEXT= yes
USE_PHP_BUILD= yes
+DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
+PORTDOCS= README.md
+
+OPTIONS_DEFINE= DOCS
+OPTIONS_DEFAULT=STACKPROTECTOR
+
+OPTIONS_RADIO= BUFFER_OVERFLOW_PROTECTION
+OPTIONS_RADIO_BUFFER_OVERFLOW_PROTECTION= STACKPROTECTOR STACKPROTECTORALL
+
+STACKPROTECTOR_DESC= Protect functions with vulnerable objects
+STACKPROTECTORALL_DESC= Protect all functions
+
+STACKPROTECTOR_CFLAGS= -fstack-protector
+STACKPROTECTORALL_CFLAGS= -fstack-protector-all
+
.include <bsd.port.pre.mk>
-.if ${ARCH} != amd64
+.if ${ARCH} != amd64 && ${COMPILER_TYPE} == gcc
post-patch:
${REINPLACE_CMD} '/emmintrin.h/d' ${WRKSRC}/config.m4
.endif
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/php/${PHP_EXT_DIR}/${PORTNAME}.so
+
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
.include <bsd.port.post.mk>