aboutsummaryrefslogtreecommitdiffstats
path: root/security/pidgin-encryption
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-05-05 14:19:18 +0800
committermarcus <marcus@FreeBSD.org>2004-05-05 14:19:18 +0800
commit3ddf270d2b7a6d91304c6188823b2254a6d44c1f (patch)
tree8c344e8feda44c089011d9ccc07d855ea80f8806 /security/pidgin-encryption
parent6d1001d0174bd6f1b470f6a6f8a1d11091a0bcb0 (diff)
downloadfreebsd-ports-gnome-3ddf270d2b7a6d91304c6188823b2254a6d44c1f.tar.gz
freebsd-ports-gnome-3ddf270d2b7a6d91304c6188823b2254a6d44c1f.tar.zst
freebsd-ports-gnome-3ddf270d2b7a6d91304c6188823b2254a6d44c1f.zip
Add gaim-encryption, a Gaim plug-in that allows for transparent RSA message
encryption between supporting clients. PR: 66236 Submitted by: ports@c0decafe.net <ports@c0decafe.net>
Diffstat (limited to 'security/pidgin-encryption')
-rw-r--r--security/pidgin-encryption/Makefile34
-rw-r--r--security/pidgin-encryption/distinfo2
-rw-r--r--security/pidgin-encryption/pkg-descr22
-rw-r--r--security/pidgin-encryption/pkg-plist1
4 files changed, 59 insertions, 0 deletions
diff --git a/security/pidgin-encryption/Makefile b/security/pidgin-encryption/Makefile
new file mode 100644
index 000000000000..21cb9f1a4326
--- /dev/null
+++ b/security/pidgin-encryption/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: gaim-encryption
+# Date created: 2004-05-01
+# Whom: ports@c0decafe.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= gaim-encryption
+PORTVERSION= 2.25
+CATEGORIES= security net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@c0decafe.net
+COMMENT= Provides transparent RSA encryption as a Gaim plugin
+
+BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/net/gaim:configure
+RUN_DEPENDS= gaim:${PORTSDIR}/net/gaim
+LIB_DEPENDS= nss3:${PORTSDIR}/security/nss
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOME= lthack gtk20
+USE_LIBTOOL_VER=13
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/nss/nss"
+CONFIGURE_ARGS= --with-gaim=${WRKDIRPREFIX}${PORTSDIR}/net/gaim/work/gaim*
+
+pre-everything::
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "WARNING: make sure net/gaim is built with NSS support (it is, by default)"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} ""
+
+.include <bsd.port.mk>
diff --git a/security/pidgin-encryption/distinfo b/security/pidgin-encryption/distinfo
new file mode 100644
index 000000000000..61e66dac074a
--- /dev/null
+++ b/security/pidgin-encryption/distinfo
@@ -0,0 +1,2 @@
+MD5 (gaim-encryption-2.25.tar.gz) = 24a112d3f8b670203d054a54a8396d72
+SIZE (gaim-encryption-2.25.tar.gz) = 357356
diff --git a/security/pidgin-encryption/pkg-descr b/security/pidgin-encryption/pkg-descr
new file mode 100644
index 000000000000..2083c7cc5370
--- /dev/null
+++ b/security/pidgin-encryption/pkg-descr
@@ -0,0 +1,22 @@
+Gaim-Encryption uses NSS to provide transparent RSA encryption as a Gaim plugin.
+
+Features include:
+ * Automatically creates a public/private key pair for you upon loading
+ the plugin
+ * Automatically transmits your public key to other users.
+ * Supports 512 - 4096 bit keys.
+ * Saves keys of known users, and warns you if their public key has
+ changed.
+ * Embeds all encryption and keys inside HTML, so if the other user
+ doesn't have the plugin, they will get a little message telling them
+ about the plugin, and won't get a screen full of garbage.
+ * Stores keys in human readable files in your .gaim directory, in case
+ you ever need to copy/edit them by hand. Which you really shouldn't
+ have to do.
+ * Automatically recognizes if you are chatting with someone who has the
+ plugin- see the Preferences dialog.
+ * Modular and extensible. If you want to define a different type of
+ encryption, you can use this plugin as a wrapper to take care of
+ transporting the encrypted binary over the IM pipe.
+
+WWW: http://gaim-encryption.sourceforge.net/
diff --git a/security/pidgin-encryption/pkg-plist b/security/pidgin-encryption/pkg-plist
new file mode 100644
index 000000000000..f4d88256e6a0
--- /dev/null
+++ b/security/pidgin-encryption/pkg-plist
@@ -0,0 +1 @@
+lib/gaim/encrypt.so