aboutsummaryrefslogtreecommitdiffstats
path: root/security/pidgin-otr/Makefile
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2005-03-20 18:31:05 +0800
committerdanfe <danfe@FreeBSD.org>2005-03-20 18:31:05 +0800
commit19dcb9314eb2db9384e36e2df5affc82977385dd (patch)
tree4335a422c448b1108aa90fa5c0d5c54f1b9da7d4 /security/pidgin-otr/Makefile
parentb0868dfedc5e6d833157bb7931102ffed18c32fb (diff)
downloadfreebsd-ports-gnome-19dcb9314eb2db9384e36e2df5affc82977385dd.tar.gz
freebsd-ports-gnome-19dcb9314eb2db9384e36e2df5affc82977385dd.tar.zst
freebsd-ports-gnome-19dcb9314eb2db9384e36e2df5affc82977385dd.zip
Add gaim-otr 1.0.1, allows deniable private conversations using GAIM.
PR: ports/75352 Submitted by: Conor McDermottroe <ports(at)mcdermottroe.com>
Diffstat (limited to 'security/pidgin-otr/Makefile')
-rw-r--r--security/pidgin-otr/Makefile52
1 files changed, 52 insertions, 0 deletions
diff --git a/security/pidgin-otr/Makefile b/security/pidgin-otr/Makefile
new file mode 100644
index 000000000000..198bee86df96
--- /dev/null
+++ b/security/pidgin-otr/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: Gaim-OTR
+# Date created: 2004-12-17
+# Whom: Conor McDermottroe <ports@mcdermottroe.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= otr
+PORTVERSION= 1.0.1
+CATEGORIES= security net
+MASTER_SITES= http://www.cypherpunks.ca/otr/
+PKGNAMEPREFIX= gaim-
+DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ports@mcdermottroe.com
+COMMENT= Allows deniable private conversations using GAIM
+
+BUILD_DEPENDS= ${X11BASE}/include/gaim/config.h:${PORTSDIR}/net/gaim \
+ pkg-config:${PORTSDIR}/devel/pkgconfig
+RUN_DEPENDS= gaim:${PORTSDIR}/net/gaim
+LIB_DEPENDS= gpg-error:${PORTSDIR}/security/libgpg-error \
+ gcrypt:${PORTSDIR}/security/libgcrypt
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOME= glib20 gtk20
+USE_REINPLACE= yes
+
+MAN1= otr_toolkit.1
+MLINKS= otr_toolkit.1 otr_parse.1 \
+ otr_toolkit.1 otr_sesskeys.1 \
+ otr_toolkit.1 otr_mackey.1 \
+ otr_toolkit.1 otr_readforge.1 \
+ otr_toolkit.1 otr_modify.1 \
+ otr_toolkit.1 otr_remac.1
+
+post-patch:
+ ${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|g" \
+ ${WRKSRC}/gaim-otr/Makefile \
+ ${WRKSRC}/libotr/Makefile \
+ ${WRKSRC}/tools/Makefile
+ ${REINPLACE_CMD} -e "s|%%X11BASE%%|${X11BASE}|g" \
+ ${WRKSRC}/gaim-otr/Makefile
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/gaim-otr.so ${PREFIX}/lib/gaim
+ ${INSTALL_MAN} ${WRKSRC}/tools/otr_toolkit.1 ${PREFIX}/man/man1
+.for P in otr_parse otr_sesskeys otr_mackey otr_readforge otr_modify otr_remac
+ ${INSTALL_PROGRAM} ${WRKSRC}/${P} ${PREFIX}/bin
+.endfor
+
+.include <bsd.port.mk>