aboutsummaryrefslogtreecommitdiffstats
path: root/security/pinentry/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2003-01-31 06:37:07 +0800
committerwill <will@FreeBSD.org>2003-01-31 06:37:07 +0800
commitb0c9d4847c3e6b709d3be880d8702f508caa0aad (patch)
tree011222856d877cc1e1c53ebce090a7402442584e /security/pinentry/Makefile
parent452861ff7e3bc87e9f8f374efad8f472e607973b (diff)
downloadfreebsd-ports-gnome-b0c9d4847c3e6b709d3be880d8702f508caa0aad.tar.gz
freebsd-ports-gnome-b0c9d4847c3e6b709d3be880d8702f508caa0aad.tar.zst
freebsd-ports-gnome-b0c9d4847c3e6b709d3be880d8702f508caa0aad.zip
Add pinentry 0.6.7, a collection of simple PIN or passphrase entry
dialogs.
Diffstat (limited to 'security/pinentry/Makefile')
-rw-r--r--security/pinentry/Makefile56
1 files changed, 56 insertions, 0 deletions
diff --git a/security/pinentry/Makefile b/security/pinentry/Makefile
new file mode 100644
index 000000000000..4bba97a95676
--- /dev/null
+++ b/security/pinentry/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: pinentry
+# Date created: 29 Jan 2003
+# Whom: michaelnottebrock@gmx.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= pinentry
+PORTVERSION= 0.6.7
+CATEGORIES= security
+MASTER_SITES= ftp://ftp.gnupg.org/gcrypt/pinentry/ \
+ http://tigress.com/lofi/
+DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz \
+ common.tar.gz \
+ jnlib.tar.gz
+
+MAINTAINER= michaelnottebrock@gmx.net
+
+BUILD_DEPENDS= autoconf:${PORTSDIR}/devel/autoconf \
+ automake:${PORTSDIR}/devel/automake
+LIB_DEPENDS= gcrypt.6:${PORTSDIR}/security/libgcrypt \
+ gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
+ ksba.7:${PORTSDIR}/security/libksba
+
+WANT_GTK= yes
+USE_LIBTOOL= yes
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
+CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
+LDFLAGS+= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CPPFLAGS="${CPPFLAGS}"
+CONFIGURE_ARGS+=--with-included-gettext=no
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_QT)
+#USE_QT_VER= 3
+BROKEN= The QT pinentry-helper is currently non-functional
+.endif
+
+.if defined(HAVE_GTK)
+USE_GTK= yes
+.endif
+
+post-extract:
+ ${MV} ${WRKDIR}/common ${WRKSRC}
+ ${MV} ${WRKDIR}/jnlib ${WRKSRC}
+
+pre-configure:
+ ${REINPLACE_CMD} -e "s@-lpthread@${PTHREAD_LIBS}@g" \
+ ${WRKSRC}/acinclude.m4 ${WRKSRC}/aclocal.m4 ${WRKSRC}/configure
+ cd ${WRKSRC}; ./autogen.sh
+
+.include <bsd.port.post.mk>