aboutsummaryrefslogtreecommitdiffstats
path: root/security/pinentry
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-02-06 20:00:29 +0800
committermakc <makc@FreeBSD.org>2013-02-06 20:00:29 +0800
commit95f5f217ab37faf2d23f9e88bf09116d72fce043 (patch)
tree1fb498f04d19a4ecdaeda3c3a6ff5e393d92561f /security/pinentry
parent891fd133134d58dd947014ae4117590015a93516 (diff)
downloadfreebsd-ports-gnome-95f5f217ab37faf2d23f9e88bf09116d72fce043.tar.gz
freebsd-ports-gnome-95f5f217ab37faf2d23f9e88bf09116d72fce043.tar.zst
freebsd-ports-gnome-95f5f217ab37faf2d23f9e88bf09116d72fce043.zip
- Fix regression introduced in my previous commit [1]
- Trim Makefile header - Adjust comment Reported by: bapt
Diffstat (limited to 'security/pinentry')
-rw-r--r--security/pinentry/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/security/pinentry/Makefile b/security/pinentry/Makefile
index aa23de7b5c3f..6d6c3b09e902 100644
--- a/security/pinentry/Makefile
+++ b/security/pinentry/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: pinentry
-# Date created: 29 Jan 2003
-# Whom: michaelnottebrock@gmx.net
-#
+# Created by: Michael Nottebrock <lofi@freebsd.org>
# $FreeBSD$
-#
PORTNAME= pinentry
PORTVERSION= 0.8.1
@@ -13,7 +9,7 @@ MASTER_SITES= ${MASTER_SITE_GNUPG}
MASTER_SITE_SUBDIR= pinentry
MAINTAINER= makc@FreeBSD.org
-COMMENT?= A collection of simple PIN or passphrase entry dialogs
+COMMENT?= Collection of simple PIN or passphrase entry dialogs
LIB_DEPENDS= gcrypt.18:${PORTSDIR}/security/libgcrypt \
ksba.19:${PORTSDIR}/security/libksba
@@ -54,7 +50,9 @@ PLIST_SUB+= WITH_QT3="@comment "
.endif
.if ${PORT_OPTIONS:MQT4}
-USE_QT4= gui moc_build
+# bsd.kde.mk overrides MOC from bsd.qt.mk
+USE_QT4= gui # moc_build
+BUILD_DEPENDS+= ${MOC4}:${PORTSDIR}/devel/qt4-moc
PLIST_SUB+= WITH_QT4=""
MOC4= ${LOCALBASE}/bin/moc-qt4
LDFLAGS+= ${PTHREAD_LIBS}