aboutsummaryrefslogtreecommitdiffstats
path: root/security/pinentry
diff options
context:
space:
mode:
authorjhale <jhale@FreeBSD.org>2016-12-16 23:31:24 +0800
committerjhale <jhale@FreeBSD.org>2016-12-16 23:31:24 +0800
commitc9af1624d57b410408f9f54aea8e78b90666ff4a (patch)
treef36200e34991f45de250ab0d23f0b2c2a48c37b5 /security/pinentry
parenta66651d6e58fbbb628b9d778edf11c9bc44be006 (diff)
downloadfreebsd-ports-gnome-c9af1624d57b410408f9f54aea8e78b90666ff4a.tar.gz
freebsd-ports-gnome-c9af1624d57b410408f9f54aea8e78b90666ff4a.tar.zst
freebsd-ports-gnome-c9af1624d57b410408f9f54aea8e78b90666ff4a.zip
Update to 1.0.0
Add LICENSE (GPLv2+) Dependency cleanup Whitespace fix Remake patches Take maintainership
Diffstat (limited to 'security/pinentry')
-rw-r--r--security/pinentry/Makefile23
-rw-r--r--security/pinentry/distinfo5
-rw-r--r--security/pinentry/files/patch-secmem_secmem.c (renamed from security/pinentry/files/patch-more_sec_mem)6
3 files changed, 18 insertions, 16 deletions
diff --git a/security/pinentry/Makefile b/security/pinentry/Makefile
index e8c15d23b07c..fd75f3cb0c86 100644
--- a/security/pinentry/Makefile
+++ b/security/pinentry/Makefile
@@ -2,14 +2,17 @@
# $FreeBSD$
PORTNAME= pinentry
-PORTVERSION= 0.9.7
-PORTREVISION?= 1
+PORTVERSION= 1.0.0
+PORTREVISION?= 0
CATEGORIES= security
MASTER_SITES= GNUPG/pinentry
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= jhale@FreeBSD.org
COMMENT?= Collection of simple PIN or passphrase entry dialogs
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
USES= tar:bzip2
.if !defined(PINENTRY_GUI)
@@ -42,7 +45,7 @@ QT4_RUN_DEPENDS= ${PINENTRY_QT4}:security/pinentry-qt4
QT5_DESC= Qt 5 frontend
PINENTRY_QT5= pinentry-qt5
-QT5_RUN_DEPENDS= ${PINENTRY_QT5}:security/pinentry-qt5
+QT5_RUN_DEPENDS= ${PINENTRY_QT5}:security/pinentry-qt5
GNOME3_DESC= GNOME 3 frontend
PINENTRY_GNOME3= pinentry-gnome3
@@ -63,21 +66,19 @@ do-install:
.else # !defined(PINENTRY_GUI)
PKGNAMESUFFIX= -${PINENTRY_GUI}
LIB_DEPENDS= libassuan.so:security/libassuan \
- libgcrypt.so:security/libgcrypt \
- libksba.so:security/libksba
+ libgpg-error.so:security/libgpg-error
-USES+= iconv gmake ncurses pkgconfig
+USES+= gmake iconv localbase ncurses pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-pinentry-emacs
-
-CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LDFLAGS+= -Wl,--as-needed
OPTIONS_DEFINE= LIBSECRET
LIBSECRET_DESC= Saving the passphrase with libsecret
LIBSECRET_CONFIGURE_ENABLE= libsecret
LIBSECRET_LIB_DEPENDS= libsecret-1.so:security/libsecret
+LIBSECRET_USE= GNOME=glib20
.if ${PINENTRY_GUI} == "gnome3"
OPTIONS_SLAVE= LIBSECRET
@@ -90,7 +91,7 @@ CONFIGURE_ARGS+=--disable-pinentry-gnome3
.if ${PINENTRY_GUI} == "qt4"
USES+= compiler:c++11-lib
-USE_QT4= gui moc_build
+USE_QT4= corelib gui moc_build
PLIST_FILES= bin/pinentry-qt4
CONFIGURE_ARGS+=--disable-pinentry-qt5 \
--program-suffix=4
diff --git a/security/pinentry/distinfo b/security/pinentry/distinfo
index 26b526b6a535..8dcc0d992a05 100644
--- a/security/pinentry/distinfo
+++ b/security/pinentry/distinfo
@@ -1,2 +1,3 @@
-SHA256 (pinentry-0.9.7.tar.bz2) = 6398208394972bbf897c3325780195584682a0d0c164ca5a0da35b93b1e4e7b2
-SIZE (pinentry-0.9.7.tar.bz2) = 432978
+TIMESTAMP = 1481880660
+SHA256 (pinentry-1.0.0.tar.bz2) = 1672c2edc1feb036075b187c0773787b2afd0544f55025c645a71b4c2f79275a
+SIZE (pinentry-1.0.0.tar.bz2) = 436930
diff --git a/security/pinentry/files/patch-more_sec_mem b/security/pinentry/files/patch-secmem_secmem.c
index 81fe8bebea74..a21d0ba2221f 100644
--- a/security/pinentry/files/patch-more_sec_mem
+++ b/security/pinentry/files/patch-secmem_secmem.c
@@ -1,6 +1,6 @@
---- secmem/secmem.c.orig 2007-07-03 05:49:48.000000000 +0600
-+++ secmem/secmem.c 2008-02-17 22:19:50.000000000 +0500
-@@ -85,7 +85,7 @@
+--- secmem/secmem.c.orig 2016-04-14 14:39:51 UTC
++++ secmem/secmem.c
+@@ -88,7 +88,7 @@ log_fatal(char *template, ...)
# define MAP_ANONYMOUS MAP_ANON
#endif