aboutsummaryrefslogtreecommitdiffstats
path: root/security/pks
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2007-01-01 23:25:35 +0800
committerleeym <leeym@FreeBSD.org>2007-01-01 23:25:35 +0800
commit9f611511e4292e295a16189c2366885dd474b8cb (patch)
treeb92c8f4ae83ef7a6034214351aae53506fde3651 /security/pks
parentbe3c2a74e4e29f3e20b448d01649f11264121324 (diff)
downloadfreebsd-ports-gnome-9f611511e4292e295a16189c2366885dd474b8cb.tar.gz
freebsd-ports-gnome-9f611511e4292e295a16189c2366885dd474b8cb.tar.zst
freebsd-ports-gnome-9f611511e4292e295a16189c2366885dd474b8cb.zip
- utilize USE_BDB
PR: 89023 Submitted by: swhetzel at gmail.com
Diffstat (limited to 'security/pks')
-rw-r--r--security/pks/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/security/pks/Makefile b/security/pks/Makefile
index bfac8267a94f..b3381a66855c 100644
--- a/security/pks/Makefile
+++ b/security/pks/Makefile
@@ -15,13 +15,14 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= gtodd@bellanet.org
COMMENT= PGP Public Key Server
-LIB_DEPENDS= db2.0:${PORTSDIR}/databases/db2
+USE_BDB= yes
+WANT_BDB_VER= 2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --datadir=${PREFIX}/share/pks --localstatedir=/var/pks \
--sysconfdir=${EXAMPLESDIR} \
--libdir=${LOCALBASE}/lib --with-libwrap
-CFLAGS+= -I${LOCALBASE}/include/db2
+CFLAGS+= -I${BDB_INCLUDE_DIR}
MAKE_ENV+= LDFLAGS=-L${LOCALBASE}/lib SUBDIRS=
USE_RC_SUBR= pksd.sh
@@ -34,8 +35,8 @@ SUB_FILES= pkg-message pkg-deinstall
post-patch:
${RM} -rf ${WRKSRC}/db2-sleepycat
${REINPLACE_CMD} 's|SUBDIRS =.*|SUBDIRS =|; \
- s|LIBDB =.*|LIBDB = -L${LOCALBASE}/lib -ldb2|; \
- s|DBDIR =.*|DBDIR = ${LOCALBASE}/include/db2|' \
+ s|LIBDB =.*|LIBDB = -L${LOCALBASE}/lib -l${BDB_LIB_NAME}|; \
+ s|DBDIR =.*|DBDIR = ${BDB_INCLUDE_DIR}|' \
${WRKSRC}/Makefile.in
post-install: