aboutsummaryrefslogtreecommitdiffstats
path: root/security/poc
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2008-01-13 00:31:19 +0800
committerarved <arved@FreeBSD.org>2008-01-13 00:31:19 +0800
commit9e0e9fc190350b8aa714f42849409eca510a3b17 (patch)
treebfac87967616527c5c6891564510f487f1878a2e /security/poc
parent8cdaecebc259a9328de50ecfe0b27b3e1cb4d82d (diff)
downloadfreebsd-ports-gnome-9e0e9fc190350b8aa714f42849409eca510a3b17.tar.gz
freebsd-ports-gnome-9e0e9fc190350b8aa714f42849409eca510a3b17.tar.zst
freebsd-ports-gnome-9e0e9fc190350b8aa714f42849409eca510a3b17.zip
Avoid the need for running autotools by replacing the patch to Makefile.am
with REINPLACE_CMDs on Makefile.in
Diffstat (limited to 'security/poc')
-rw-r--r--security/poc/Makefile9
-rw-r--r--security/poc/files/patch-src_Makefile.am12
2 files changed, 7 insertions, 14 deletions
diff --git a/security/poc/Makefile b/security/poc/Makefile
index ba69f56fc710..2200867424ee 100644
--- a/security/poc/Makefile
+++ b/security/poc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= poc
PORTVERSION= 1.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR=poc
@@ -20,8 +20,13 @@ LIB_DEPENDS= towitoko.2:${PORTSDIR}/devel/towitoko
PLIST_FILES= bin/poc
USE_GETOPT_LONG=yes
USE_GMAKE= yes
-USE_AUTOTOOLS= automake:14 autoconf:213
+GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+post-patch:
+ ${REINPLACE_CMD} -e "s,^CFLAGS,#CFLAGS,; \
+ s,^CPPFLAGS =,CPPFLAGS = ${CPPFLAGS} -I${LOCALBASE}/include," \
+ ${WRKSRC}/src/Makefile.in
+
.include <bsd.port.mk>
diff --git a/security/poc/files/patch-src_Makefile.am b/security/poc/files/patch-src_Makefile.am
deleted file mode 100644
index 24959c9bcc62..000000000000
--- a/security/poc/files/patch-src_Makefile.am
+++ /dev/null
@@ -1,12 +0,0 @@
-
-$FreeBSD$
-
---- src/Makefile.am.orig Thu Jul 25 16:35:09 2002
-+++ src/Makefile.am Thu Jul 25 16:35:18 2002
-@@ -30,6 +30,4 @@
-
- # debugging
- #CFLAGS = -g -Wall
--CFLAGS = -Wall -O2
--CPPFLAGS =
-