aboutsummaryrefslogtreecommitdiffstats
path: root/security/pssh/Makefile
diff options
context:
space:
mode:
authorbrooks <brooks@FreeBSD.org>2007-07-07 04:30:24 +0800
committerbrooks <brooks@FreeBSD.org>2007-07-07 04:30:24 +0800
commit1add4b987f8d4054522ddc48031428c8b31bb41b (patch)
treefcc472aabfb77da1ae188fdda2fbce5e05a27474 /security/pssh/Makefile
parented3c68885c60b29827c654092bfd3452fa04d603 (diff)
downloadfreebsd-ports-gnome-1add4b987f8d4054522ddc48031428c8b31bb41b.tar.gz
freebsd-ports-gnome-1add4b987f8d4054522ddc48031428c8b31bb41b.tar.zst
freebsd-ports-gnome-1add4b987f8d4054522ddc48031428c8b31bb41b.zip
Fix a couple bugs and remove the IGNORE variable:
- select can be interrupted and return EINTR so we need to loop around it while it does so rather than treating it as a fatal error. - all process creations are matched with a wait() so having a SIGCHLD handler that performs a wait(-1) is pointless and racy. We tend to loose the race over half the time and as a result were reporting successful processes as failed. Add a couple features: - Skip commented lines in the host specification. - Allow '-' as an alias for stdin in the host file specification.
Diffstat (limited to 'security/pssh/Makefile')
-rw-r--r--security/pssh/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/security/pssh/Makefile b/security/pssh/Makefile
index d7c2fb597d2b..e3a4d8daf00c 100644
--- a/security/pssh/Makefile
+++ b/security/pssh/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pssh
PORTVERSION= 1.3.1
+PORTREVISION= 1
CATEGORIES= security net sysutils
MASTER_SITES= http://www.theether.org/pssh/ \
${MASTER_SITE_LOCAL}
@@ -19,8 +20,6 @@ BUILD_DEPENDS= easy_install:${PORTSDIR}/devel/py-setuptools
RUN_DEPENDS= easy_install:${PORTSDIR}/devel/py-setuptools \
rsync:${PORTSDIR}/net/rsync
-IGNORE= most connections fail with bogus error
-
USE_PYTHON= YES
USE_PYDISTUTILS=yes