aboutsummaryrefslogtreecommitdiffstats
path: root/security/pwman/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-10-09 05:32:20 +0800
committerpav <pav@FreeBSD.org>2005-10-09 05:32:20 +0800
commit600c447d1ee77366da70ae38f9bab0b80bf4b8ff (patch)
treede4aa05b3bed6cf0b7bd709f660b473ffa8477f5 /security/pwman/Makefile
parent2264fbb2f8b78488fb9801e59fb43ec3a0eabecf (diff)
downloadfreebsd-ports-gnome-600c447d1ee77366da70ae38f9bab0b80bf4b8ff.tar.gz
freebsd-ports-gnome-600c447d1ee77366da70ae38f9bab0b80bf4b8ff.tar.zst
freebsd-ports-gnome-600c447d1ee77366da70ae38f9bab0b80bf4b8ff.zip
- Fix handling of & sign, it need to be escaped for XML storage
PR: ports/85240 Submitted by: Maurice Castro <maurice@sphinx.clari.net.au> Approved by: maintainer timeout (anders, 17 days) - While here, fix runtime crash on 64bit platforms by explicitly declaring getenv() (via including <stdlib.h> header)
Diffstat (limited to 'security/pwman/Makefile')
-rw-r--r--security/pwman/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/security/pwman/Makefile b/security/pwman/Makefile
index 024394a7c603..ba12701de766 100644
--- a/security/pwman/Makefile
+++ b/security/pwman/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pwman
PORTVERSION= 0.3.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -19,11 +19,15 @@ LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
RUN_DEPENDS= gpg:${PORTSDIR}/security/gnupg
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
MAN1= pwman.1
DOCS= AUTHORS COPYING ChangeLog README TODO
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/bin/gpg|${LOCALBASE}/bin/gpg|g' ${WRKSRC}/src/misc.c
+
.if !defined(NOPORTDOCS)
post-install:
@${INSTALL} -d -m 0755 ${DOCSDIR}