aboutsummaryrefslogtreecommitdiffstats
path: root/security/pwman3
diff options
context:
space:
mode:
authoreadler <eadler@FreeBSD.org>2011-09-23 07:00:25 +0800
committereadler <eadler@FreeBSD.org>2011-09-23 07:00:25 +0800
commitf2b0b6849a976545c4c129ce02111cedfdd1579b (patch)
tree1f600d1d34cda930b1659febd90b2f5f3e3e7624 /security/pwman3
parent17a6ff99b4c7b0bb4e6833b9df7163cf707a88fe (diff)
downloadfreebsd-ports-gnome-f2b0b6849a976545c4c129ce02111cedfdd1579b.tar.gz
freebsd-ports-gnome-f2b0b6849a976545c4c129ce02111cedfdd1579b.tar.zst
freebsd-ports-gnome-f2b0b6849a976545c4c129ce02111cedfdd1579b.zip
- remove dep on databases/py-pysqlite23
- patch program to not use old pysqlite - fix whitespace issue in pkg-descr - bump portrevision PR: ports/160288 Submitted by: Ruslan Mahmatkhanov <cvs-src@yandex.ru> Approved by: maintainer timeout (23 days) Approved by: sahil (mentor)
Diffstat (limited to 'security/pwman3')
-rw-r--r--security/pwman3/Makefile4
-rw-r--r--security/pwman3/files/patch-pwman-data-drivers_sqlite.py11
-rw-r--r--security/pwman3/files/patch-pwman-exchange_exporter.py11
-rw-r--r--security/pwman3/files/patch-pwman-exchange_importer.py11
-rw-r--r--security/pwman3/pkg-descr4
5 files changed, 37 insertions, 4 deletions
diff --git a/security/pwman3/Makefile b/security/pwman3/Makefile
index 11da9aea5159..ed2720641f9e 100644
--- a/security/pwman3/Makefile
+++ b/security/pwman3/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pwman3
PORTVERSION= 0.0.6
+PORTREVISION= 1
CATEGORIES= security python
MASTER_SITES= http://pwman.bleurgh.com/~ivan/pwman3/source/ \
http://source.antisupport.com/pwman3/
@@ -16,8 +17,7 @@ MAINTAINER= yarodin@gmail.com
COMMENT= Console password management application with sql storage
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycrypto>=2.0:${PORTSDIR}/security/py-pycrypto \
- ${PYTHON_PKGNAMEPREFIX}cElementTree>=1.0.5:${PORTSDIR}/devel/py-celementtree \
- ${PYTHON_PKGNAMEPREFIX}pysqlite>=2.0.5:${PORTSDIR}/databases/py-pysqlite23
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>=0:${PORTSDIR}/databases/py-sqlite3
USE_PYTHON= 2.5+
USE_PYDISTUTILS= yes
diff --git a/security/pwman3/files/patch-pwman-data-drivers_sqlite.py b/security/pwman3/files/patch-pwman-data-drivers_sqlite.py
new file mode 100644
index 000000000000..42e7500bb796
--- /dev/null
+++ b/security/pwman3/files/patch-pwman-data-drivers_sqlite.py
@@ -0,0 +1,11 @@
+--- pwman/data/drivers/sqlite.py.orig 2007-02-04 21:44:43.000000000 +0300
++++ pwman/data/drivers/sqlite.py 2011-08-29 21:02:34.000000000 +0400
+@@ -22,7 +22,7 @@
+ from pwman.data.nodes import Node
+ from pwman.data.tags import Tag
+
+-from pysqlite2 import dbapi2 as sqlite
++from sqlite3 import dbapi2 as sqlite
+ import pwman.util.config as config
+ import cPickle
+
diff --git a/security/pwman3/files/patch-pwman-exchange_exporter.py b/security/pwman3/files/patch-pwman-exchange_exporter.py
new file mode 100644
index 000000000000..97db2c68fec6
--- /dev/null
+++ b/security/pwman3/files/patch-pwman-exchange_exporter.py
@@ -0,0 +1,11 @@
+--- pwman/exchange/exporter.py.orig 2007-02-04 21:44:43.000000000 +0300
++++ pwman/exchange/exporter.py 2011-08-29 21:07:59.000000000 +0400
+@@ -17,7 +17,7 @@
+ # Copyright (C) 2006 Ivan Kelly <ivan@ivankelly.net>
+ #============================================================================
+
+-from cElementTree import Element, SubElement, dump, ElementTree
++from xml.etree.cElementTree import Element, SubElement, dump, ElementTree
+ from pwman.data.nodes import Node
+ from pwman.data.tags import Tag
+
diff --git a/security/pwman3/files/patch-pwman-exchange_importer.py b/security/pwman3/files/patch-pwman-exchange_importer.py
new file mode 100644
index 000000000000..a7d765c5ec52
--- /dev/null
+++ b/security/pwman3/files/patch-pwman-exchange_importer.py
@@ -0,0 +1,11 @@
+--- pwman/exchange/importer.py.orig 2007-02-04 21:44:43.000000000 +0300
++++ pwman/exchange/importer.py 2011-08-29 21:07:49.000000000 +0400
+@@ -17,7 +17,7 @@
+ # Copyright (C) 2006 Ivan Kelly <ivan@ivankelly.net>
+ #============================================================================
+
+-import cElementTree as ET
++import xml.etree.cElementTree as ET
+ from pwman.data.nodes import Node
+ from pwman.data.tags import Tag
+
diff --git a/security/pwman3/pkg-descr b/security/pwman3/pkg-descr
index a90be2da7d2c..8779866a006d 100644
--- a/security/pwman3/pkg-descr
+++ b/security/pwman3/pkg-descr
@@ -1,5 +1,5 @@
-Pwman3 is a console based password management application.
-Pwman3 is written in python. It uses sql for storage
+Pwman3 is a console based password management application.
+Pwman3 is written in python. It uses sql for storage
and all data is encrypted when it isn't being viewed on screen.
WWW: http://pwman.bleurgh.com