aboutsummaryrefslogtreecommitdiffstats
path: root/security/py-bcrypt
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-03-11 22:50:41 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-03-11 22:50:41 +0800
commit22685f6b99aa960110b151a6c0f70bbe4f1275d0 (patch)
treea0ac78f74378938944e19d6ee9c3413ae6e243bf /security/py-bcrypt
parentce076fec444e255956336721b1b84fcd4232a50f (diff)
downloadfreebsd-ports-gnome-22685f6b99aa960110b151a6c0f70bbe4f1275d0.tar.gz
freebsd-ports-gnome-22685f6b99aa960110b151a6c0f70bbe4f1275d0.tar.zst
freebsd-ports-gnome-22685f6b99aa960110b151a6c0f70bbe4f1275d0.zip
- Add LICENSE
- Strip library
Diffstat (limited to 'security/py-bcrypt')
-rw-r--r--security/py-bcrypt/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/security/py-bcrypt/Makefile b/security/py-bcrypt/Makefile
index c99bb68cace0..f3b7ec31f9a9 100644
--- a/security/py-bcrypt/Makefile
+++ b/security/py-bcrypt/Makefile
@@ -3,7 +3,7 @@
PORTNAME= bcrypt
PORTVERSION= 0.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security python
MASTER_SITES= GOOGLE_CODE \
http://www.mindrot.org/files/py-bcrypt/
@@ -13,6 +13,10 @@ DISTNAME= py-${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Python bcrypt module
+LICENSE= MIT BSD3CLAUSE BSD4CLAUSE
+LICENSE_COMB= multi
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
USES= python
USE_PYTHON= distutils autoplist
@@ -21,4 +25,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
PROJECTHOST= py-bcrypt
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/bcrypt/_bcrypt.so
+
.include <bsd.port.mk>