aboutsummaryrefslogtreecommitdiffstats
path: root/security/py-cryptography
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2014-02-23 21:47:04 +0800
committerkoobs <koobs@FreeBSD.org>2014-02-23 21:47:04 +0800
commit49280d45c7c8beb17e6310f83efe000eb8eb6236 (patch)
treed5962983f5423a2a345db818a47cfe6b6746ff2b /security/py-cryptography
parentc3d2ea1d97118ac44006ace96f661075ad2c02b3 (diff)
downloadfreebsd-ports-gnome-49280d45c7c8beb17e6310f83efe000eb8eb6236.tar.gz
freebsd-ports-gnome-49280d45c7c8beb17e6310f83efe000eb8eb6236.tar.zst
freebsd-ports-gnome-49280d45c7c8beb17e6310f83efe000eb8eb6236.zip
[NEW PORT] security/py-cryptography: Cryptographic recipes and primitives to Python developers
cryptography is a package designed to expose cryptographic recipes and primitives to Python developers. Our goal is for it to be your "cryptographic standard library". It supports Python 2.6-2.7, Python 3.2+, and PyPy. cryptography includes both high level recipes, and low level interfaces to common cryptographic algorithms such as symmetric ciphers, message digests and key derivation functions. WWW: http://github.com/pyca/cryptography/
Diffstat (limited to 'security/py-cryptography')
-rw-r--r--security/py-cryptography/Makefile22
-rw-r--r--security/py-cryptography/distinfo2
-rw-r--r--security/py-cryptography/pkg-descr9
3 files changed, 33 insertions, 0 deletions
diff --git a/security/py-cryptography/Makefile b/security/py-cryptography/Makefile
new file mode 100644
index 000000000000..4be6e1798437
--- /dev/null
+++ b/security/py-cryptography/Makefile
@@ -0,0 +1,22 @@
+# Created by: Kubilay Kocak <koobs@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= cryptography
+PORTVERSION= 0.2.1
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= koobs@FreeBSD.org
+COMMENT= Expose cryptographic recipes and primitives to Python developers
+
+LICENSE= APACHE20
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=0.8:${PORTSDIR}/devel/py-cffi \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.4.1:${PORTSDIR}/devel/py-six
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/security/py-cryptography/distinfo b/security/py-cryptography/distinfo
new file mode 100644
index 000000000000..32098f010526
--- /dev/null
+++ b/security/py-cryptography/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cryptography-0.2.1.tar.gz) = 5b4b93a9841364396ac75ee3f0f4550752821df5a89078c1e16a716339ba39a3
+SIZE (cryptography-0.2.1.tar.gz) = 13772304
diff --git a/security/py-cryptography/pkg-descr b/security/py-cryptography/pkg-descr
new file mode 100644
index 000000000000..db1565bcab16
--- /dev/null
+++ b/security/py-cryptography/pkg-descr
@@ -0,0 +1,9 @@
+cryptography is a package designed to expose cryptographic recipes and
+primitives to Python developers. Our goal is for it to be your "cryptographic
+standard library". It supports Python 2.6-2.7, Python 3.2+, and PyPy.
+
+cryptography includes both high level recipes, and low level interfaces to
+common cryptographic algorithms such as symmetric ciphers, message digests
+and key derivation functions.
+
+WWW: http://github.com/pyca/cryptography/