aboutsummaryrefslogtreecommitdiffstats
path: root/security/py-cryptography
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2014-03-08 17:12:34 +0800
committerkoobs <koobs@FreeBSD.org>2014-03-08 17:12:34 +0800
commit6d271a3d189e983d4737f4cd47a7d7e0dc063cf1 (patch)
tree5c7f9cbee2697f40a690de7812bc9dbb10a77b1f /security/py-cryptography
parenta94c10e41b56ec83e43ed8243d628dc45bbbb4a0 (diff)
downloadfreebsd-ports-gnome-6d271a3d189e983d4737f4cd47a7d7e0dc063cf1.tar.gz
freebsd-ports-gnome-6d271a3d189e983d4737f4cd47a7d7e0dc063cf1.tar.zst
freebsd-ports-gnome-6d271a3d189e983d4737f4cd47a7d7e0dc063cf1.zip
security/py-cryptography: BUILD_DEPENDS are also RUN_DEPENDS
Add BUILD_DEPENDS (cffi and six) to RUN_DEPENDS as they are needed at run time Reported by: antoine
Diffstat (limited to 'security/py-cryptography')
-rw-r--r--security/py-cryptography/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/security/py-cryptography/Makefile b/security/py-cryptography/Makefile
index d9707317d4af..8d898901cd0b 100644
--- a/security/py-cryptography/Makefile
+++ b/security/py-cryptography/Makefile
@@ -3,6 +3,7 @@
PORTNAME= cryptography
PORTVERSION= 0.2.2
+PORTREVISION= 1
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,6 +15,7 @@ LICENSE= APACHE20
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=0.8:${PORTSDIR}/devel/py-cffi \
${PYTHON_PKGNAMEPREFIX}six>=1.4.1:${PORTSDIR}/devel/py-six
+RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:${PORTSDIR}/devel/py-pytest
USE_OPENSSL= yes