aboutsummaryrefslogtreecommitdiffstats
path: root/security/py-kerberos
diff options
context:
space:
mode:
authorcs <cs@FreeBSD.org>2011-10-02 13:21:18 +0800
committercs <cs@FreeBSD.org>2011-10-02 13:21:18 +0800
commit53c74bc322bd78d97547c53193fb7139871ac4ca (patch)
treef57e813e5abfbb97e487b39ccda59e017d4d8c6f /security/py-kerberos
parent675e9e70c6b8d1d00b4bbb3005d15edcad0f1fa6 (diff)
downloadfreebsd-ports-gnome-53c74bc322bd78d97547c53193fb7139871ac4ca.tar.gz
freebsd-ports-gnome-53c74bc322bd78d97547c53193fb7139871ac4ca.tar.zst
freebsd-ports-gnome-53c74bc322bd78d97547c53193fb7139871ac4ca.zip
This Python package is a high-level wrapper for Kerberos (GSSAPI) operations.
The goal is to avoid having to build a module that wraps the entire Kerberos.framework, and instead offer a limited set of functions that do what is needed for client/server Kerberos authentication based on <http://www.ietf.org/rfc/rfc4559.txt>. PR: ports/156791 Submitted by: Roland van Laar <roland@micite.net> Approved by: wen@ (co-mentor)
Diffstat (limited to 'security/py-kerberos')
-rw-r--r--security/py-kerberos/Makefile31
-rw-r--r--security/py-kerberos/distinfo2
-rw-r--r--security/py-kerberos/pkg-descr7
-rw-r--r--security/py-kerberos/pkg-plist1
4 files changed, 41 insertions, 0 deletions
diff --git a/security/py-kerberos/Makefile b/security/py-kerberos/Makefile
new file mode 100644
index 000000000000..df7800791bbe
--- /dev/null
+++ b/security/py-kerberos/Makefile
@@ -0,0 +1,31 @@
+# Ports collection makefile for: py-kerberos
+# Date created: April 23, 2011
+# Whom: Roland van Laar <roland@micite.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kerberos
+PORTVERSION= 1.1.1
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= roland@micite.net
+COMMENT= Kerberos bindings for python
+
+LICENSE= ASL
+
+BUILD_DEPENDS= krb5-config:${PORTSDIR}/security/krb5
+LIB_DEPENDS= krb5support.0:${PORTSDIR}/security/krb5
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+PYEASYINSTALL_ARCHDEP= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|krb5|${PREFIX}/bin/krb5|g' ${WRKSRC}/setup.py
+ @${REINPLACE_CMD} -e 's|split|replace("/usr/lib:", "").split|g' ${WRKSRC}/setup.py
+ @${REINPLACE_CMD} -e 's|distutils.core|setuptools|g' ${WRKSRC}/setup.py
+
+.include <bsd.port.mk>
diff --git a/security/py-kerberos/distinfo b/security/py-kerberos/distinfo
new file mode 100644
index 000000000000..50cbebcc751d
--- /dev/null
+++ b/security/py-kerberos/distinfo
@@ -0,0 +1,2 @@
+SHA256 (kerberos-1.1.1.tar.gz) = 09132e3b2027854e8714894546aff11f31e6051eb75513e774948e10a5dde6f5
+SIZE (kerberos-1.1.1.tar.gz) = 15343
diff --git a/security/py-kerberos/pkg-descr b/security/py-kerberos/pkg-descr
new file mode 100644
index 000000000000..30291a330635
--- /dev/null
+++ b/security/py-kerberos/pkg-descr
@@ -0,0 +1,7 @@
+This Python package is a high-level wrapper for Kerberos (GSSAPI) operations.
+The goal is to avoid having to build a module that wraps the entire
+Kerberos.framework, and instead offer a limited set of functions that do what is
+needed for client/server Kerberos authentication based on
+<http://www.ietf.org/rfc/rfc4559.txt>.
+
+WWW: http://trac.calendarserver.org/
diff --git a/security/py-kerberos/pkg-plist b/security/py-kerberos/pkg-plist
new file mode 100644
index 000000000000..ddf68a1c022f
--- /dev/null
+++ b/security/py-kerberos/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%