aboutsummaryrefslogtreecommitdiffstats
path: root/security/py-passlib
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2016-03-04 13:54:53 +0800
committerkoobs <koobs@FreeBSD.org>2016-03-04 13:54:53 +0800
commitcb676eb551f939d5b60cd00aacf6c6c175e8518f (patch)
tree5b7a9ca62b4f58d3efb6f86f7113c8bc9edc0a8f /security/py-passlib
parent74ec8b9054b31ad6e4e4cd8482f395bfe1a37386 (diff)
downloadfreebsd-ports-gnome-cb676eb551f939d5b60cd00aacf6c6c175e8518f.tar.gz
freebsd-ports-gnome-cb676eb551f939d5b60cd00aacf6c6c175e8518f.tar.zst
freebsd-ports-gnome-cb676eb551f939d5b60cd00aacf6c6c175e8518f.zip
security/py-passlib: Update to 1.6.5
- Update PORTVERSION and distinfo checksum (1.6.5) - Add LICENSE_FILE - Add TEST_DEPENDS and test target - Add comment about failing tests which appear to require fixing bcrypt in FreeBSD base - Remove setup.py patch (no longer necessary) - Update pkg-descr WWW: URL (match setup.py:url) - Enable NO_ARCH (architecture independent) Changes: http://packages.python.org/passlib/history.html
Diffstat (limited to 'security/py-passlib')
-rw-r--r--security/py-passlib/Makefile16
-rw-r--r--security/py-passlib/distinfo4
-rw-r--r--security/py-passlib/files/patch-setup.py17
-rw-r--r--security/py-passlib/pkg-descr2
4 files changed, 18 insertions, 21 deletions
diff --git a/security/py-passlib/Makefile b/security/py-passlib/Makefile
index c5b8ea4546f1..1d93935937be 100644
--- a/security/py-passlib/Makefile
+++ b/security/py-passlib/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= passlib
-PORTVERSION= 1.6.2
+PORTVERSION= 1.6.5
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,8 +11,22 @@ MAINTAINER= koobs@FreeBSD.org
COMMENT= Python password hashing framework supporting over 30 schemes
LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>=1.1:${PORTSDIR}/devel/py-nose
USES= python
USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+# A number of (bcrypt) tests are failing due to:
+# AssertionError: sanity check failed: 'os_crypt' backend supports $2b$ but has wraparound bug
+# See:
+# WRKSRC/passlib/handlers/bcrypt.py#306
+# http://www.openwall.com/lists/oss-security/2012/01/02/4
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+
.include <bsd.port.mk>
diff --git a/security/py-passlib/distinfo b/security/py-passlib/distinfo
index de5db9b24eef..ea30999f92d0 100644
--- a/security/py-passlib/distinfo
+++ b/security/py-passlib/distinfo
@@ -1,2 +1,2 @@
-SHA256 (passlib-1.6.2.tar.gz) = e987f6000d16272f75314c7147eb015727e8532a3b747b1a8fb58e154c68392d
-SIZE (passlib-1.6.2.tar.gz) = 408950
+SHA256 (passlib-1.6.5.tar.gz) = a83d34f53dc9b17aa42c9a35c3fbcc5120f3fcb07f7f8721ec45e6a27be347fc
+SIZE (passlib-1.6.5.tar.gz) = 417044
diff --git a/security/py-passlib/files/patch-setup.py b/security/py-passlib/files/patch-setup.py
deleted file mode 100644
index e6ab1c8429ef..000000000000
--- a/security/py-passlib/files/patch-setup.py
+++ /dev/null
@@ -1,17 +0,0 @@
---- ./setup.py.orig 2012-06-11 20:52:21.000000000 +1000
-+++ ./setup.py 2012-06-11 20:52:35.000000000 +1000
-@@ -15,12 +15,8 @@
-
- py3k = (sys.version_info[0] >= 3)
-
--try:
-- from setuptools import setup
-- has_distribute = True
--except ImportError:
-- from distutils.core import setup
-- has_distribute = False
-+from distutils.core import setup
-+has_distribute = False
-
- #=========================================================
- # init setup options
diff --git a/security/py-passlib/pkg-descr b/security/py-passlib/pkg-descr
index 6cdb4a883bbc..958b5da55b14 100644
--- a/security/py-passlib/pkg-descr
+++ b/security/py-passlib/pkg-descr
@@ -4,4 +4,4 @@ as a framework for managing existing password hashes. It's designed to be
useful for a wide range of tasks, from verifying a hash found in /etc/shadow,
to providing full-strength password hashing for multi-user application.
-WWW: http://passlib.googlecode.com
+WWW: https://bitbucket.org/ecollins/passlib