aboutsummaryrefslogtreecommitdiffstats
path: root/security/py-plaso
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-06-07 16:43:31 +0800
committerantoine <antoine@FreeBSD.org>2014-06-07 16:43:31 +0800
commit66ea863ccc830e526acfc0f51f95e0b7a28b927f (patch)
tree495a5e94b2022fb4acc5c849538493f9e467d2b2 /security/py-plaso
parente56248606a76d57f54b919607025145f72e208b5 (diff)
downloadfreebsd-ports-gnome-66ea863ccc830e526acfc0f51f95e0b7a28b927f.tar.gz
freebsd-ports-gnome-66ea863ccc830e526acfc0f51f95e0b7a28b927f.tar.zst
freebsd-ports-gnome-66ea863ccc830e526acfc0f51f95e0b7a28b927f.zip
- Update plaso to 1.1.0
Announce: http://blog.kiddaland.net/2014/06/what-is-one-to-say-about-june-time-of.html - Add converters/py-bencode, bencoding and bdecoding implementation
Diffstat (limited to 'security/py-plaso')
-rw-r--r--security/py-plaso/Makefile19
-rw-r--r--security/py-plaso/distinfo4
-rw-r--r--security/py-plaso/files/patch-plaso__parsers__firefox.py22
-rw-r--r--security/py-plaso/files/patch-setup.py20
4 files changed, 19 insertions, 46 deletions
diff --git a/security/py-plaso/Makefile b/security/py-plaso/Makefile
index 68bdc7d78836..974279f808f7 100644
--- a/security/py-plaso/Makefile
+++ b/security/py-plaso/Makefile
@@ -2,13 +2,11 @@
# $FreeBSD$
PORTNAME= plaso
-PORTVERSION= 1.0.2
-PORTREVISION= 1
+PORTVERSION= 1.1.0
CATEGORIES= security python
-MASTER_SITES= https://googledrive.com/host/0B30H7z4S52FleW5vUHBnblJfcjg/${PORTVERSION}/final/ \
+MASTER_SITES= https://googledrive.com/host/0B30H7z4S52FleW5vUHBnblJfcjg/${PORTVERSION}/release/ \
LOCAL/antoine
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= ${PORTNAME}_source_${PORTVERSION}
MAINTAINER= antoine@FreeBSD.org
COMMENT= Automatic creation of a super timeline
@@ -18,21 +16,24 @@ LICENSE= APACHE20
RUN_DEPENDS= hachoir-core>=0:${PORTSDIR}/devel/hachoir-core \
hachoir-metadata>=0:${PORTSDIR}/sysutils/hachoir-metadata \
hachoir-parser>=0:${PORTSDIR}/devel/hachoir-parser \
+ libesedb>=e:${PORTSDIR}/devel/libesedb \
libevt>=a:${PORTSDIR}/devel/libevt \
libevtx>=a:${PORTSDIR}/devel/libevtx \
liblnk>=0:${PORTSDIR}/devel/liblnk \
libmsiecf>=a:${PORTSDIR}/devel/libmsiecf \
libolecf>=a:${PORTSDIR}/devel/libolecf \
libregf>=a:${PORTSDIR}/devel/libregf \
- libvshadow>=0:${PORTSDIR}/devel/libvshadow \
+ ${PYTHON_PKGNAMEPREFIX}bencode>=0:${PORTSDIR}/converters/py-bencode \
${PYTHON_PKGNAMEPREFIX}binplist>=0:${PORTSDIR}/devel/py-binplist \
${PYTHON_PKGNAMEPREFIX}construct>=0:${PORTSDIR}/devel/py-construct \
${PYTHON_PKGNAMEPREFIX}dateutil>=0:${PORTSDIR}/devel/py-dateutil \
- ${PYTHON_PKGNAMEPREFIX}docopt>=0:${PORTSDIR}/devel/py-docopt \
+ ${PYTHON_PKGNAMEPREFIX}dfvfs>=0:${PORTSDIR}/security/py-dfvfs \
${PYTHON_PKGNAMEPREFIX}dpkt>=0:${PORTSDIR}/net/py-dpkt \
${PYTHON_PKGNAMEPREFIX}ipython>=0:${PORTSDIR}/devel/ipython \
${PYTHON_PKGNAMEPREFIX}parsing>=0:${PORTSDIR}/devel/py-parsing \
${PYTHON_PKGNAMEPREFIX}protobuf>=0:${PORTSDIR}/devel/py-protobuf \
+ ${PYTHON_PKGNAMEPREFIX}psutil121>=0:${PORTSDIR}/sysutils/py-psutil121 \
+ ${PYTHON_PKGNAMEPREFIX}pyelasticsearch>=0:${PORTSDIR}/textproc/py-pyelasticsearch \
${PYTHON_PKGNAMEPREFIX}pytsk>=0:${PORTSDIR}/sysutils/py-pytsk \
${PYTHON_PKGNAMEPREFIX}pytz>=0:${PORTSDIR}/devel/py-pytz \
${PYTHON_PKGNAMEPREFIX}sqlite3>=0:${PORTSDIR}/databases/py-sqlite3 \
@@ -41,13 +42,9 @@ RUN_DEPENDS= hachoir-core>=0:${PORTSDIR}/devel/hachoir-core \
USE_PYTHON= 2
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
-PORTDOCS= ACKNOWLEDGEMENT AUTHORS
-DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
+PORTDOCS= ACKNOWLEDGEMENTS AUTHORS
PORTEXAMPLES= *
-EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
OPTIONS_DEFINE= DOCS EXAMPLES
diff --git a/security/py-plaso/distinfo b/security/py-plaso/distinfo
index 940ee396fc29..10f86d432bf0 100644
--- a/security/py-plaso/distinfo
+++ b/security/py-plaso/distinfo
@@ -1,2 +1,2 @@
-SHA256 (plaso_source_1.0.2.tar.gz) = 6dffc50864a38258ae8f6bedba1cd6910aa8792f632e55eb6bfd93d1b415bc98
-SIZE (plaso_source_1.0.2.tar.gz) = 14514319
+SHA256 (plaso-1.1.0.tar.gz) = f0eae193c2714b241547fa68779c9e6eb467ef34be78c6d6299851818bed73f7
+SIZE (plaso-1.1.0.tar.gz) = 39526513
diff --git a/security/py-plaso/files/patch-plaso__parsers__firefox.py b/security/py-plaso/files/patch-plaso__parsers__firefox.py
deleted file mode 100644
index 982cb9b06c76..000000000000
--- a/security/py-plaso/files/patch-plaso__parsers__firefox.py
+++ /dev/null
@@ -1,22 +0,0 @@
---- ./plaso/parsers/firefox.py.orig 2013-10-31 18:02:07.000000000 +0000
-+++ ./plaso/parsers/firefox.py 2013-11-15 23:23:14.000000000 +0000
-@@ -26,18 +26,9 @@
-
- # Check SQlite version, bail out early if too old.
- import sqlite3
--release, major, minor = sqlite3.sqlite_version_info
--if (release < 3):
-+if sqlite3.sqlite_version_info < (3, 7, 8):
- raise ImportWarning(
- 'FirefoxHistoryParser requires at least SQLite version 3.7.8.')
--elif release == 3:
-- if major < 7:
-- raise ImportWarning(
-- 'FirefoxHistoryParser requires at least SQLite version 3.7.8.')
-- elif major == 7:
-- if minor < 8:
-- raise ImportWarning(
-- 'FirefoxHistoryParser requires at least SQLite version 3.7.8.')
-
-
- class FirefoxPlacesBookmarkAnnotation(event.EventContainer):
diff --git a/security/py-plaso/files/patch-setup.py b/security/py-plaso/files/patch-setup.py
index 297751a607e2..81bfee2a9ed5 100644
--- a/security/py-plaso/files/patch-setup.py
+++ b/security/py-plaso/files/patch-setup.py
@@ -1,11 +1,9 @@
---- ./setup.py.orig 2013-10-31 18:02:07.000000000 +0000
-+++ ./setup.py 2014-01-26 09:42:25.000000000 +0000
-@@ -104,7 +104,7 @@
- 'Programming Language :: Python',
- ],
- #include_package_data=True,
-- packages=find_packages('.'),
-+ packages=find_packages('.', exclude=['test_data']),
- package_data={'plaso.test_data': GetFileList('test_data', ['*'])},
- )
-
+--- ./setup.py.orig 2014-05-25 08:56:12.000000000 +0000
++++ ./setup.py 2014-06-06 12:47:49.000000000 +0000
+@@ -106,5 +106,5 @@
+ 'Programming Language :: Python',
+ ],
+ package_dir={'plaso': 'plaso'},
+- packages=find_packages('.'),
++ packages=find_packages('.', exclude=['test_data', 'tools']),
+ )