aboutsummaryrefslogtreecommitdiffstats
path: root/security/py-pow
diff options
context:
space:
mode:
authorjkim <jkim@FreeBSD.org>2017-04-04 01:33:48 +0800
committerjkim <jkim@FreeBSD.org>2017-04-04 01:33:48 +0800
commitff67aa1f5e4b6dd083f8fd2cb6242285dd3ae22d (patch)
tree782d9fe8a3e3be1925e89134d9899c3e1182707e /security/py-pow
parentfa60cc0e6953a2b1d19e9e37e027ae81cbaeda9e (diff)
downloadfreebsd-ports-gnome-ff67aa1f5e4b6dd083f8fd2cb6242285dd3ae22d.tar.gz
freebsd-ports-gnome-ff67aa1f5e4b6dd083f8fd2cb6242285dd3ae22d.tar.zst
freebsd-ports-gnome-ff67aa1f5e4b6dd083f8fd2cb6242285dd3ae22d.zip
Remove obsolete OpenSSL hacks for IDEA crypto.
We have some hacks in the ports tree to detect or to unconditionally disable IDEA crypto support. These hacks existed because OpenSSL in FreeBSD 9.3 and earlier was shipped without IDEA support by default but we were allowed to enable it via WITH_IDEA src.conf(5) option. https://www.freebsd.org/cgi/man.cgi?query=src.conf&manpath=FreeBSD+9.3-RELEASE Therefore, we had to implement some hacks to support three different cases, i.e., a) 9.3 and earlier without IDEA crypto (default), b) 9.3 and earlier with IDEA crypto (via WITH_IDEA src.conf option), and c) 10.0 and later with unconditional IDEA support. Now we can safely remove them because 9.3 and earlier is no longer supported. PR: 218233 Exp-Run by: antoine Approved by: antoine (portmgr)
Diffstat (limited to 'security/py-pow')
-rw-r--r--security/py-pow/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/security/py-pow/Makefile b/security/py-pow/Makefile
index 5f7ea2c6d9e9..7148a3234b0a 100644
--- a/security/py-pow/Makefile
+++ b/security/py-pow/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pow
PORTVERSION= 0.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security python
MASTER_SITES= SF/${PORTNAME}/POW/POW-${PORTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -26,7 +26,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|licence|license|' ${WRKSRC}/setup.py
do-build:
- cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} build_ext -D NO_IDEA -D NO_RC5_32_12_16 ${PYDISTUTILS_BUILD_TARGET}
+ cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} build_ext -D NO_RC5_32_12_16 ${PYDISTUTILS_BUILD_TARGET}
post-install:
@${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/POW/_POW.so