aboutsummaryrefslogtreecommitdiffstats
path: root/security/py-pyaff4
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2018-05-25 01:23:45 +0800
committerantoine <antoine@FreeBSD.org>2018-05-25 01:23:45 +0800
commite28970c3097856afdd8e941c1db832c4e2a4fbe8 (patch)
tree28a80c591b581d987cec192513fa69995030dcc6 /security/py-pyaff4
parent154aff9fbd6b3b6ab437eb4d63e432fab75f037c (diff)
downloadfreebsd-ports-gnome-e28970c3097856afdd8e941c1db832c4e2a4fbe8.tar.gz
freebsd-ports-gnome-e28970c3097856afdd8e941c1db832c4e2a4fbe8.tar.zst
freebsd-ports-gnome-e28970c3097856afdd8e941c1db832c4e2a4fbe8.zip
Update to 0.26.post6
Diffstat (limited to 'security/py-pyaff4')
-rw-r--r--security/py-pyaff4/Makefile16
-rw-r--r--security/py-pyaff4/distinfo6
-rw-r--r--security/py-pyaff4/files/patch-setup.py19
3 files changed, 31 insertions, 10 deletions
diff --git a/security/py-pyaff4/Makefile b/security/py-pyaff4/Makefile
index 8b96756832c1..f15c40d38fb1 100644
--- a/security/py-pyaff4/Makefile
+++ b/security/py-pyaff4/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= pyaff4
-DISTVERSION= 0.24.post1
+DISTVERSION= 0.26.post6
CATEGORIES= security devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,15 +12,17 @@ COMMENT= Python Advanced Forensic Format Version 4 library
LICENSE= APACHE20
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}intervaltree>=2.1.0:devel/py-intervaltree@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}python-snappy>=0.5:archivers/py-python-snappy@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}rdflib>=4.2.1:textproc/py-rdflib@${FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}future>=0:devel/py-future@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}python-snappy>=0.5.1:archivers/py-python-snappy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}rdflib>=4.2.2:textproc/py-rdflib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}intervaltree>=2.1.0:devel/py-intervaltree@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyblake2>=0.9.3:security/py-pyblake2@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}expiringdict>=1.1.4:devel/py-expiringdict@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}html5lib>=0:www/py-html5lib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yaml>=0:devel/py-yaml@${PY_FLAVOR}
NO_ARCH= yes
USES= python zip
USE_PYTHON= distutils autoplist
-post-patch:
- ${REINPLACE_CMD} 's/aff4-snappy == 0.5/python-snappy >= 0.5/' ${WRKSRC}/setup.py
-
.include <bsd.port.mk>
diff --git a/security/py-pyaff4/distinfo b/security/py-pyaff4/distinfo
index 4341577219fa..a06c1d27a6ef 100644
--- a/security/py-pyaff4/distinfo
+++ b/security/py-pyaff4/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1468658152
-SHA256 (pyaff4-0.24.post1.zip) = b30eb08407b78e80a1d9b6ab8d67213ea0cc9f93e217d5f3f9a51bad5a6469cf
-SIZE (pyaff4-0.24.post1.zip) = 54592
+TIMESTAMP = 1516106167
+SHA256 (pyaff4-0.26.post6.zip) = 142aefb2876b0f4e4ebfbe1347805cba58a82636bd90c89dbd732f88e87dc8f2
+SIZE (pyaff4-0.26.post6.zip) = 76010
diff --git a/security/py-pyaff4/files/patch-setup.py b/security/py-pyaff4/files/patch-setup.py
new file mode 100644
index 000000000000..0e7383953b31
--- /dev/null
+++ b/security/py-pyaff4/files/patch-setup.py
@@ -0,0 +1,19 @@
+--- setup.py.orig 2017-12-05 23:36:26 UTC
++++ setup.py
+@@ -56,11 +56,11 @@ setup(
+ package_dir={"pyaff4": "pyaff4"},
+ install_requires=[
+ "future",
+- "aff4-snappy == 0.5.1",
+- "rdflib[sparql] == 4.2.2",
+- "intervaltree == 2.1.0",
+- "pyblake2 == 0.9.3",
+- "expiringdict == 1.1.4",
++ "python-snappy >= 0.5.1",
++ "rdflib[sparql] >= 4.2.2",
++ "intervaltree >= 2.1.0",
++ "pyblake2 >= 0.9.3",
++ "expiringdict >= 1.1.4",
+ "html5lib",
+ ],
+ extras_require=dict(