aboutsummaryrefslogtreecommitdiffstats
path: root/security/py-pycrypto/Makefile
diff options
context:
space:
mode:
authorlwhsu <lwhsu@FreeBSD.org>2009-07-16 21:46:55 +0800
committerlwhsu <lwhsu@FreeBSD.org>2009-07-16 21:46:55 +0800
commit7408d58d582766a14be1b9a5be3773439d286b3a (patch)
tree73c03cb11d6516a70038ac55757d03e162383ec0 /security/py-pycrypto/Makefile
parent430a12a48c7975d965f5084bdbe0a79576990735 (diff)
downloadfreebsd-ports-gnome-7408d58d582766a14be1b9a5be3773439d286b3a.tar.gz
freebsd-ports-gnome-7408d58d582766a14be1b9a5be3773439d286b3a.tar.zst
freebsd-ports-gnome-7408d58d582766a14be1b9a5be3773439d286b3a.zip
- Add a patch to make SHA and MD5 use hashlib if possible
- Transfer maintainership to submitter PR: ports/135832 Submitted by: Keith Gaughan <kmgaughan AT eircom.net>
Diffstat (limited to 'security/py-pycrypto/Makefile')
-rw-r--r--security/py-pycrypto/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/security/py-pycrypto/Makefile b/security/py-pycrypto/Makefile
index 4753a1d98422..6b4005fb8008 100644
--- a/security/py-pycrypto/Makefile
+++ b/security/py-pycrypto/Makefile
@@ -7,12 +7,12 @@
PORTNAME= pycrypto
PORTVERSION= 2.0.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= security python
MASTER_SITES= http://www.amk.ca/files/python/crypto/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= kmgaughan@eircom.net
COMMENT= The Python Cryptography Toolkit
USE_PYTHON= yes
@@ -23,4 +23,10 @@ LIB_DEPENDS+= gmp.8:${PORTSDIR}/math/libgmp4
pre-configure:
@${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|" ${WRKSRC}/setup.py
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if (${PYTHON_REL} >= 250)
+EXTRA_PATCHES+= ${FILESDIR}/python25+.txt
+.endif
+
+.include <bsd.port.post.mk>