aboutsummaryrefslogtreecommitdiffstats
path: root/security/py-ssh
diff options
context:
space:
mode:
authorlwhsu <lwhsu@FreeBSD.org>2011-12-20 14:31:36 +0800
committerlwhsu <lwhsu@FreeBSD.org>2011-12-20 14:31:36 +0800
commitcfef2998c480a19218ba4c84fe3ce8c329fc9cc4 (patch)
treea4a0a007c27dc36a2fbf2116c0475e85597e1414 /security/py-ssh
parentc429823eaa712e04779ea14fc621236cc5b86ef4 (diff)
downloadfreebsd-ports-gnome-cfef2998c480a19218ba4c84fe3ce8c329fc9cc4.tar.gz
freebsd-ports-gnome-cfef2998c480a19218ba4c84fe3ce8c329fc9cc4.tar.zst
freebsd-ports-gnome-cfef2998c480a19218ba4c84fe3ce8c329fc9cc4.zip
- Remove explicit dependency in setup.py for `python ./setup.py test`
Requested by: clsung
Diffstat (limited to 'security/py-ssh')
-rw-r--r--security/py-ssh/Makefile2
-rw-r--r--security/py-ssh/files/patch-setup.py10
2 files changed, 11 insertions, 1 deletions
diff --git a/security/py-ssh/Makefile b/security/py-ssh/Makefile
index e5b28b959e45..50f125d2d2bc 100644
--- a/security/py-ssh/Makefile
+++ b/security/py-ssh/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ssh
PORTVERSION= 1.7.11
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/security/py-ssh/files/patch-setup.py b/security/py-ssh/files/patch-setup.py
new file mode 100644
index 000000000000..162595012903
--- /dev/null
+++ b/security/py-ssh/files/patch-setup.py
@@ -0,0 +1,10 @@
+--- setup.py.orig 2011-12-20 14:19:49.418637581 +0800
++++ setup.py 2011-12-20 14:20:31.345637126 +0800
+@@ -38,7 +38,6 @@
+ try:
+ from setuptools import setup
+ kw = {
+- 'install_requires': 'pycrypto >= 2.1, != 2.4',
+ }
+ except ImportError:
+ from distutils.core import setup