aboutsummaryrefslogtreecommitdiffstats
path: root/security/py-trustedpickle
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2006-05-09 19:46:02 +0800
committeritetcu <itetcu@FreeBSD.org>2006-05-09 19:46:02 +0800
commitdccf77cf7dc7b3074f2b6a7f1f11cca96c1bd477 (patch)
treed0a7f6afba6585dfc75aeb0c5f8e656af413982a /security/py-trustedpickle
parent189f4154c5dd844e04f85ea33c6d38d1d809117f (diff)
downloadfreebsd-ports-gnome-dccf77cf7dc7b3074f2b6a7f1f11cca96c1bd477.tar.gz
freebsd-ports-gnome-dccf77cf7dc7b3074f2b6a7f1f11cca96c1bd477.tar.zst
freebsd-ports-gnome-dccf77cf7dc7b3074f2b6a7f1f11cca96c1bd477.zip
TrustedPickle is a Python module that can save most any arbitrary Python object
in a signed pickle file. There are two big differences between this module and the standard pickle module. First, TrustedPickle can pickle a module, but the standard pickle module cannot. Second, TrustedPickle includes a signature that can verify the data's origin before the data is unpickled. WWW: http://trustedpickle.sourceforge.net/index.html PR: ports/96691 Submitted by: Alexander Botero-Lowry <alex@foxybanana.com> Approved by: lawrance (mentor)
Diffstat (limited to 'security/py-trustedpickle')
-rw-r--r--security/py-trustedpickle/Makefile38
-rw-r--r--security/py-trustedpickle/distinfo3
-rw-r--r--security/py-trustedpickle/files/patch-TrustedPickle.py10
-rw-r--r--security/py-trustedpickle/pkg-descr7
4 files changed, 58 insertions, 0 deletions
diff --git a/security/py-trustedpickle/Makefile b/security/py-trustedpickle/Makefile
new file mode 100644
index 000000000000..9a0bd86ed2d3
--- /dev/null
+++ b/security/py-trustedpickle/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: py-trustedpickle
+# Date created: 02 May 2006
+# Whom: Alexander Botero-Lowry <alex@foxybanana.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= trustedpickle
+PORTVERSION= 0.02
+CATEGORIES= security python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= TrustedPickle
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= alex@foxybanana.com
+COMMENT= TrustedPickle is a Python (de)Pickler with a way to verify the data
+
+USE_PYTHON= yes
+USE_DOS2UNIX= yes
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/TrustedPickle.py \
+ %%PYTHON_SITELIBDIR%%/TrustedPickle.pyc \
+ %%PYTHON_SITELIBDIR%%/TrustedPickle.pyo
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+do-build:
+ @cd ${WRKSRC} && ${PYTHON_CMD} -OOOO -c 'import TrustedPickle' && \
+ ${PYTHON_CMD} -c 'import TrustedPickle'
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/TrustedPickle.py ${PYTHON_SITELIBDIR}
+ ${INSTALL_DATA} ${WRKSRC}/TrustedPickle.pyc ${PYTHON_SITELIBDIR}
+ ${INSTALL_DATA} ${WRKSRC}/TrustedPickle.pyo ${PYTHON_SITELIBDIR}
+
+.include <bsd.port.mk>
diff --git a/security/py-trustedpickle/distinfo b/security/py-trustedpickle/distinfo
new file mode 100644
index 000000000000..17332249f333
--- /dev/null
+++ b/security/py-trustedpickle/distinfo
@@ -0,0 +1,3 @@
+MD5 (TrustedPickle.tgz) = 578cd6d7c114e914d12e04ea540b9f67
+SHA256 (TrustedPickle.tgz) = 06a99ddb6b245edc1e3d69a95b9b0ec5f666eefd39d6817dda5e2c19a167a29c
+SIZE (TrustedPickle.tgz) = 21437
diff --git a/security/py-trustedpickle/files/patch-TrustedPickle.py b/security/py-trustedpickle/files/patch-TrustedPickle.py
new file mode 100644
index 000000000000..9d73c434448c
--- /dev/null
+++ b/security/py-trustedpickle/files/patch-TrustedPickle.py
@@ -0,0 +1,10 @@
+--- TrustedPickle.py.orig Tue May 2 14:20:14 2006
++++ TrustedPickle.py Tue May 2 14:20:24 2006
+@@ -82,6 +82,7 @@
+ Low-level functions in this module you should not need to call:
+
+ Hash(): used in signing a string
++"""
+
+ import cPickle
+ import getpass
diff --git a/security/py-trustedpickle/pkg-descr b/security/py-trustedpickle/pkg-descr
new file mode 100644
index 000000000000..929ae9bf5b82
--- /dev/null
+++ b/security/py-trustedpickle/pkg-descr
@@ -0,0 +1,7 @@
+TrustedPickle is a Python module that can save most any arbitrary Python object
+ in a signed pickle file. There are two big differences between this module and
+ the standard pickle module. First, TrustedPickle can pickle a module, but the
+standard pickle module cannot. Second, TrustedPickle includes a signature that
+can verify the data's origin before the data is unpickled.
+
+WWW: http://trustedpickle.sourceforge.net/index.html